【问题标题】:XAMPP : MySQL shutdown unexpectedly INNODB warningsXAMPP:MySQL 意外关闭 INNODB 警告
【发布时间】:2016-05-19 08:44:27
【问题描述】:

一切正常,但突然 MySQL 停止工作并在启动前意外关闭。我尝试了基于其他堆栈溢出答案的各种解决方案。

  1. 我删除了C:\xampp\mysql\data 中的ibdata1 并重新启动了XAMPP = Not Resolved
  2. 我删除了所有自定义数据库文件夹,只保留了最初安装时存在的那些文件夹 = 未解决

错误日志文件显示:

2016-02-09 16:47:08 1430 InnoDB: Warning: Using innodb_additional_mem_pool_size is DEPRECATED. This option may be removed in future releases, together with the option innodb_use_sys_malloc and with the InnoDB's internal memory allocator.
160209 16:47:08 [Note] InnoDB: Using mutexes to ref count buffer pool pages
160209 16:47:08 [Note] InnoDB: The InnoDB memory heap is disabled
160209 16:47:08 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
160209 16:47:08 [Note] InnoDB: Memory barrier is not used
160209 16:47:08 [Note] InnoDB: Compressed tables use zlib 1.2.3
160209 16:47:08 [Note] InnoDB: Not using CPU crc32 instructions
160209 16:47:08 [Note] InnoDB: Initializing buffer pool, size = 16.0M
160209 16:47:08 [Note] InnoDB: Completed initialization of buffer pool
160209 16:47:08 [Note] InnoDB: The first specified data file C:\xampp\mysql\data\ibdata1 did not exist: a new database to be created!
160209 16:47:08 [Note] InnoDB: Setting file C:\xampp\mysql\data\ibdata1 size to 10 MB
160209 16:47:08 [Note] InnoDB: Database physically writes the file full: wait...
160209 16:47:08 [ERROR] InnoDB: Cannot create C:\xampp\mysql\data\ib_logfile101
160209 16:47:08 [ERROR] Plugin 'InnoDB' init function returned error.
160209 16:47:08 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
160209 16:47:08 [Note] Plugin 'FEEDBACK' is disabled.
160209 16:47:08 [ERROR] Unknown/unsupported storage engine: InnoDB
160209 16:47:08 [ERROR] Aborting

160209 16:47:08 [Note] c:\xampp\mysql\bin\mysqld.exe: Shutdown complete

【问题讨论】:

  • 如果删除了ibdata1(不是最好的主意,但已经完成)您是否也删除了ib_logfile*?重命名比删除更可取。
  • @Michael-sqlbot 是的,实际上我将这些文件重命名为 .bkp 并且没有被删除。是的,我也重命名了 ib_logfile*s。新的被创建但得到同样的错误。上次我不得不重新安装来解决这个问题,但是在安装 xampp 几天后我又遇到了同样的问题。
  • 啊,那很好。我觉得很奇怪[ERROR] InnoDB: Cannot create C:\xampp\mysql\data\ib_logfile101 之前没有立即出现错误消息或代码,并且本身也不包含错误消息或代码。我们可以假设您有足够的可用磁盘空间吗?这是什么版本的 MySQL 服务器? (我正在查看源代码,试图找出这个错误是在哪里产生的,到目前为止还没有发现它。)
  • @Michael-sqlbot 我使用的是 XAMPP 版本 5.6.15。磁盘空间不是问题,C 盘有 300GB 可用空间。过去几周我在 XAMPP 中遇到的这个问题。重新安装可以解决问题,但几天后会出现同样的问题。
  • 好的,但这部分日志只是关于您尝试从问题中恢复的内容,并没有提供任何关于最初出现问题的提示。另外,我会检查 5.6.15 的源代码。

标签: mysql xampp innodb


【解决方案1】:

在不同的论坛上询问后,我没有找到解决方案。我不得不重新安装,它又发生了。然后我在stackoverflow的某个地方遇到了一个答案,即没有以管理员身份启动xampp并将其关闭会导致mysql随着时间的推移而损坏。因此,请转到属性并确保它始终以管理员身份运行。希望其他找到这背后原因的人得到答案。

【讨论】:

  • 感谢您提供答案!
  • 我找到了很多解决这个问题的方法,只是说“以管理员身份运行”而不是考虑安全影响,对于同样的问题,我可以在命令行上以非特权身份运行 Mysql,为什么?这也是个好问题。
猜你喜欢
  • 2019-01-31
  • 1970-01-01
  • 2020-10-08
  • 2017-11-17
  • 1970-01-01
  • 2015-11-21
  • 2020-10-26
  • 1970-01-01
  • 1970-01-01
相关资源
最近更新 更多