【问题标题】:InnoDB: File (unknown): 'read' returned OS error 0InnoDB:文件(未知):“读取”返回操作系统错误 0
【发布时间】:2015-03-18 04:25:15
【问题描述】:

我需要一些有关 xampp 3.2.1 中 MySql 的帮助。 MySql 服务无法启动,我找不到原因,因为错误日志文件报告它无法从“未知文件”读取,并且只返回错误 0。 我不知道这意味着什么,因为它基本上是在尝试读取未知文件时出现 0 错误。 这是错误日志:

2015-01-20 10:36:12 760 [Note] Plugin 'FEDERATED' is disabled.
2015-01-20 10:36:12 574 InnoDB: Warning: Using innodb_additional_mem_pool_size is DEPRECATED. This option may be removed in future releases, together with the option innodb_use_sys_malloc and with the InnoDB's internal memory allocator.
2015-01-20 10:36:12 760 [Note] InnoDB: Using atomics to ref count buffer pool pages
2015-01-20 10:36:12 760 [Note] InnoDB: The InnoDB memory heap is disabled
2015-01-20 10:36:12 760 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2015-01-20 10:36:12 760 [Note] InnoDB: Memory barrier is not used
2015-01-20 10:36:12 760 [Note] InnoDB: Compressed tables use zlib 1.2.3
2015-01-20 10:36:12 760 [Note] InnoDB: Not using CPU crc32 instructions
2015-01-20 10:36:12 760 [Note] InnoDB: Initializing buffer pool, size = 16.0M
2015-01-20 10:36:12 760 [Note] InnoDB: Completed initialization of buffer pool
2015-01-20 10:36:12 760 [Note] InnoDB: Highest supported file format is Barracuda.
2015-01-20 10:36:12 760 [Note] InnoDB: The log sequence numbers 1665234 and 1665234 in ibdata files do not match the log sequence number 131153885 in the ib_logfiles!
2015-01-20 10:36:12 760 [Note] InnoDB: Database was not shutdown normally!
2015-01-20 10:36:12 760 [Note] InnoDB: Starting crash recovery.
2015-01-20 10:36:12 760 [Note] InnoDB: Reading tablespace information from the .ibd files...
2015-01-20 10:36:12 760 [ERROR] InnoDB: File (unknown): 'read' returned OS error 0. Cannot continue operation

请帮忙。

【问题讨论】:

    标签: mysql xampp


    【解决方案1】:

    这是一个不同的错误代码,但看看它是否有效。

    通过“Config”->“my.ini”打开MySQL配置文件。

    插入 innodb_flush_method = normal

    之间 innodb_lock_wait_timeout = 50## UTF 8 Settings

    在 xampp 中再次启动 MySQL。

    https://community.apachefriends.org/f/viewtopic.php?f=16&t=72437

    【讨论】:

    • 很好的解决方案,马上解决我的问题!
    • 也修复了我的问题。
    【解决方案2】:

    我遇到了完全相同的问题 - 运行相同版本的 XAMPP,它刚刚开始与您的问题同时发生。

    试试这个。打开你的 XAMPP 目录并转到 XAMPP/mysql/Data

    剪切所有文件(ibdata*、auto.cnf、mysql.pid)并将它们放在其他地方。

    尝试启动 Mysql - 如果效果很好,如果不行,您可能需要做的就是查看日志中哪个 DB 给您带来问题 - 并移动相应的文件夹。

    幸运的是,这将解决您的问题 - 对我来说很好!

    【讨论】:

    • 感谢 Bren1818 的回复,希望它早点到来。我已经重新安装了我的 xampp,遗憾的是我的一些未备份的数据库也用它重新安装了。 :(
    • 您绝不能删除 ibdata - 您的所有 InnoDB 表都将丢失
    • @noonex - 这就是为什么我说剪切(移动)而不是删除
    • talk.plesk.com/threads/… by CIJ 我这样做 2) 备份并删除 --> /var/lib/mysql 下的 ib_logfile0 和 ib_logfile1 文件,它对我有用。
    猜你喜欢
    • 2019-06-23
    • 2012-06-19
    • 2013-05-18
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2018-07-09
    • 1970-01-01
    • 2022-07-02
    相关资源
    最近更新 更多