【发布时间】:2015-03-18 04:25:15
【问题描述】:
我需要一些有关 xampp 3.2.1 中 MySql 的帮助。 MySql 服务无法启动,我找不到原因,因为错误日志文件报告它无法从“未知文件”读取,并且只返回错误 0。 我不知道这意味着什么,因为它基本上是在尝试读取未知文件时出现 0 错误。 这是错误日志:
2015-01-20 10:36:12 760 [Note] Plugin 'FEDERATED' is disabled.
2015-01-20 10:36:12 574 InnoDB: Warning: Using innodb_additional_mem_pool_size is DEPRECATED. This option may be removed in future releases, together with the option innodb_use_sys_malloc and with the InnoDB's internal memory allocator.
2015-01-20 10:36:12 760 [Note] InnoDB: Using atomics to ref count buffer pool pages
2015-01-20 10:36:12 760 [Note] InnoDB: The InnoDB memory heap is disabled
2015-01-20 10:36:12 760 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2015-01-20 10:36:12 760 [Note] InnoDB: Memory barrier is not used
2015-01-20 10:36:12 760 [Note] InnoDB: Compressed tables use zlib 1.2.3
2015-01-20 10:36:12 760 [Note] InnoDB: Not using CPU crc32 instructions
2015-01-20 10:36:12 760 [Note] InnoDB: Initializing buffer pool, size = 16.0M
2015-01-20 10:36:12 760 [Note] InnoDB: Completed initialization of buffer pool
2015-01-20 10:36:12 760 [Note] InnoDB: Highest supported file format is Barracuda.
2015-01-20 10:36:12 760 [Note] InnoDB: The log sequence numbers 1665234 and 1665234 in ibdata files do not match the log sequence number 131153885 in the ib_logfiles!
2015-01-20 10:36:12 760 [Note] InnoDB: Database was not shutdown normally!
2015-01-20 10:36:12 760 [Note] InnoDB: Starting crash recovery.
2015-01-20 10:36:12 760 [Note] InnoDB: Reading tablespace information from the .ibd files...
2015-01-20 10:36:12 760 [ERROR] InnoDB: File (unknown): 'read' returned OS error 0. Cannot continue operation
请帮忙。
【问题讨论】: