【问题标题】:Can't start Symfony 2.7 on the localhost无法在本地主机上启动 Symfony 2.7
【发布时间】:2017-01-18 16:05:16
【问题描述】:

我的 Ubuntu 16.04 上有一个 symfony 框架(v 2.7),我想通过在框架目录中运行以下命令在 XAMP 本地服务器上启动:

php app/console server:run

但是当我在终端中运行它时,我得到以下错误:

Warning: require_once(/opt/lampp/htdocs/WorkSpace/my-project/frameWork/app/bootstrap.php.cache): failed to open stream: No such file or directory in /opt/lampp/htdocs/WorkSpace/my-project/frameWork/app/console on line 10
PHP Fatal error:  require_once(): Failed opening required '/opt/lampp/htdocs/WorkSpace/my-project/frameWork/app/bootstrap.php.cache' (include_path='.:/opt/lampp/lib/php') in /opt/lampp/htdocs/WorkSpace/my-project/frameWork/app/console on line 10

Fatal error: require_once(): Failed opening required '/opt/lampp/htdocs/WorkSpace/my-project/frameWork/app/bootstrap.php.cache' (include_path='.:/opt/lampp/lib/php') in /opt/lampp/htdocs/WorkSpace/my-project/frameWork/app/console on line 10

经过一些研究,我认为我应该运行composer update 或/和composer install 命令来生成引导缓存文件并修复问题。

但是一旦我全局安装了 composer 并在框架的目录中运行了 composer update,似乎 composer 正在使用一个不在 XAMP 文件夹中的 php(尽管我已将我的 $PATH 设置为 /opt/lampp/bin)。

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/20151012/curl.so' - /usr/lib/php/20151012/curl.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/20151012/mcrypt.so' - /usr/lib/php/20151012/mcrypt.so: cannot open shared object file: No such file or directory in Unknown on line 0
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for ahmedsamy/hype-mailchimp-bundle dev-master -> satisfiable by ahmedsamy/hype-mailchimp-bundle[dev-master].
    - ahmedsamy/hype-mailchimp-bundle dev-master requires ext-curl * -> the requested PHP extension curl is missing from your system.
  Problem 2
    - aws/aws-sdk-php 2.5.0 requires guzzle/guzzle >=3.7.0,<3.9.0 -> satisfiable by guzzle/guzzle[v3.7.0, v3.7.1, v3.7.2, v3.7.3, v3.7.4, v3.8.0, v3.8.1].
    - aws/aws-sdk-php 2.5.1 requires guzzle/guzzle >=3.7.0,<....

它说 Unable to load dynamic library '/usr/lib/php ,而我希望它使用的 php 位于灯文件夹 /opt/lampp/bin 中。

当我运行which php 时,它会显示 XAMP 正在使用的正确 php。

所以现在我不知道如何告诉作曲家使用灯泡文件夹中的 php,而 composer update 是首先解决此问题的方法。

【问题讨论】:

    标签: php linux symfony xampp composer-php


    【解决方案1】:

    您是否尝试将 XAMP PHP 版本添加到您的路径中(即在您的 .bash_profile 或等效项中)?

    export PATH=/opt/lampp/bin:$PATH
    

    PS : 不要忘记之后重新加载你的 shell

    【讨论】:

      猜你喜欢
      • 2020-04-20
      • 2016-10-21
      • 2019-09-05
      • 1970-01-01
      • 2016-09-30
      • 2020-03-11
      • 2014-04-29
      • 1970-01-01
      • 2018-12-04
      相关资源
      最近更新 更多