【问题标题】:Apache Reverse Proxy ErrorApache 反向代理错误
【发布时间】:2012-12-07 15:09:42
【问题描述】:

我的网络系统:

互联网Apache 反向代理Apache 应用服务器

客户端访问互联网的 URL:www.example.com

我的问题:

当我访问 www.example.com 并上传数据时(这是 excel 文件)。我收到以下错误:

代理错误

代理服务器收到来自上游服务器的无效响应。 代理服务器无法处理请求 POST /index.php/adminstrator/store/substore/import/.

原因:从远程服务器读取错误

Apache/2.2.3 (CentOS) 服务器位于 www.example.com 端口 80

为了解决这个问题,我在 httpd.conf 中设置了配置:

KeepAlive On
MaxKeepAliveRequest 0
KeepAliveTimeout 7200 

但它仍然给我同样的错误。

【问题讨论】:

    标签: apache proxy reverse-proxy


    【解决方案1】:

    我们通过在 httpd.conf 中设置以下内容解决了类似的错误:

    SetEnv proxy-initial-not-pooled
    

    我相信这似乎是 Apache 2.2.x 的一个错误。

    希望这对某人有所帮助。

    【讨论】:

      猜你喜欢
      • 2016-04-28
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 2014-09-07
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      相关资源
      最近更新 更多