【问题标题】:How to clear apache piped rotate logs under /wslogs on http server instances如何清除 http 服务器实例上 /wslogs 下的 apache 管道旋转日志
【发布时间】:2017-04-18 13:31:56
【问题描述】:

我们的 httpd.conf 文件中有以下内容:-

ErrorLog "| /usr/HTTPServer/bin/rotatelogs /wslogs/instance_name/hostname_%m%d%Y_error.log 86400"

CustomLog "| /usr/HTTPServer/bin/rotatelogs /wslogs/instance_name/hostname_%m%d%Y_access.log 86400" 合并

这会使用上述格式将管道日志写入 /wslogs/instance_name。

我们发现这些日志文件很快就会占据 /wslogs 下的全部空间,而我们并没有意识到这一点。 然后,当我们进行部署时也有重启服务器的步骤时,服务器无法重启并出现错误:- httpd(无 pid 文件)未运行 写入文件 /wslogs/instance_name/server_name_12022016_error.log 时出错

然后我们必须手动清理 wslogs 文件夹。 有没有办法自动处理这个问题并确保这些日志只存在最近 10 天,或者换句话说,有一种方法可以删除 10 天以上的日志。

这里的任何建议/解决方案将不胜感激。

【问题讨论】:

  • 您的启动错误很可能是因为您删除的是 instance_name 目录,而不仅仅是其内容。

标签: apache httpd.conf httpserver logrotate ibmhttpserver


【解决方案1】:

您无法使用 http 服务器本身管理历史文件。您需要使用外部的东西,例如 logrotate 或您自己的 cron 脚本。

【讨论】:

    猜你喜欢
    • 2013-01-05
    • 2014-12-25
    • 2013-05-16
    • 2015-10-31
    • 2015-08-30
    • 1970-01-01
    • 2014-02-26
    • 1970-01-01
    • 2016-09-08
    相关资源
    最近更新 更多