【问题标题】:Unable to Load SSL Module in IBM HTTP Server v8.5无法在 IBM HTTP Server v8.5 中加载 SSL 模块
【发布时间】:2015-04-18 18:03:10
【问题描述】:

昨天我能够成功安装 IBM HTTP Server,并且一切正常,直到我尝试开始配置 SSL 设置。

当尝试通过将以下内容添加到我的 httpd.conf 文件来加载 SSL 模块时:

LoadModule ibm_ssl_module modules/mod_ibm_ssl.so

...服务器将无法启动,我在 error_log 中看到以下内容:

[Tue Feb 17 16:33:29 2015] [info] mod_unique_id: using ip addr <removed>
(20019)DSO load failed: SSL0166E: Failure attempting to load GSK library (libgsk8ssl_64.so), libgsk8ssl_64.so: cannot open sharedobject file: No such file or directory
Configuration Failed

我已确认我已使用 gskver 命令安装了 GSKit:

libgsk8ssl_64.so
============
@(#)CompanyName:      IBM Corporation
@(#)LegalTrademarks:  IBM
@(#)FileDescription:  IBM Global Security Toolkit
@(#)FileVersion:      8.0.50.34
@(#)InternalName:     gskssl
@(#)LegalCopyright:   Licensed Materials - Property of IBM GSKit 
                      (C) Copyright IBM Corp.1995, 2014 
                      All Rights Reserved. US Government Users 
                      Restricted Rights - Use, duplication or disclosure
                      restricted by GSA ADP Schedule Contract with IBM     Corp.
@(#)OriginalFilename: libgsk8ssl_64.so
@(#)ProductName:      gsk8g (GoldCoast Build) 140910
@(#)ProductVersion:   8.0.50.34
@(#)ProductInfo:      14/08/13.01:22:06.14/09/10.13:23:58
@(#)CMVCInfo:         gsk8g_140909/gsk8g_ssl gsk8g_140909/gsk8g_cms gsk8g_140909/gsk8g_support gsk8g_140731/gsk8g_pkg gsk8g_140909/gsk8g_acme gsk8g_140909/gsk8g_doc gsk8g_140909/gsk8g_ikm

似乎没有其他模块导致任何问题。我对造成这种情况的原因感到有些不知所措。有什么想法吗?

【问题讨论】:

    标签: apache ssl ibmhttpserver


    【解决方案1】:

    我发现 /usr/lib 和 /usr/lib64 中缺少共享库符号链接。如果您(重新)创建这些链接,它可能会清除您的问题。我导航到库目录(在本例中为 /usr/lib64)并运行(以 root 身份):

    对于 $(ls -1 /opt/IBM/WebSphere/HTTPServer85/gsk8/lib64) 中的名称; 执行 ln -s /opt/IBM/WebSphere/HTTPServer85/gsk8/lib64/$name ./$name; 完成

    当然,将源目录更改为您的安装标准。它在我的案例中创建了所有必要的链接。

    一个。

    【讨论】:

      【解决方案2】:

      查看 apachectl 和 envars 脚本。特别是恩瓦斯。有时会修改这些脚本以运行第三方模块。 GSKit 库的路径通常在 envars 脚本中设置。

      【讨论】:

      • 谢谢马尔夫!我不知道apachectl 脚本。只需将其替换为使用 httpd 来启动服务器即可解决问题。
      猜你喜欢
      • 1970-01-01
      • 1970-01-01
      • 2016-12-13
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 2011-03-08
      • 1970-01-01
      • 2013-11-10
      相关资源
      最近更新 更多