【问题标题】:Can't restart webmin [status 2]无法重新启动 webmin [状态 2]
【发布时间】:2019-01-05 18:39:40
【问题描述】:

我已经更新了 webmin,但现在它拒绝重启:

● webmin.service - LSB: web-based administration interface for Unix systems
  Loaded: loaded (/etc/init.d/webmin; generated; vendor preset: enabled)
  Active: failed (Result: exit-code) since Sun 2018-07-29 09:30:29 CEST; 12s ago
  Docs: man:systemd-sysv-generator(8)
  Process: 1485 ExecStart=/etc/init.d/webmin start (code=exited, status=2)

  Jul 29 09:30:26 vps513135 systemd[1]: Starting LSB: web-based administration interface for Unix systems...
  Jul 29 09:30:27 vps513135 perl[1486]: pam_unix(webmin:auth): authentication failure; logname= uid=0 euid=0 tty= ruser= rhost=  user=root
  Jul 29 09:30:29 vps513135 systemd[1]: webmin.service: Control process exited, code=exited status=2
  Jul 29 09:30:29 vps513135 systemd[1]: Failed to start LSB: web-based administration interface for Unix systems.
  Jul 29 09:30:29 vps513135 systemd[1]: webmin.service: Unit entered failed state.
  Jul 29 09:30:29 vps513135 systemd[1]: webmin.service: Failed with result 'exit-code'.

谁能解释一下pam_unix(webmin:auth): authentication failure 是什么意思?

更多信息:

root@vps513135:~# uname -a
Linux vps513135 4.9.0-7-amd64 #1 SMP Debian 4.9.110-1 (2018-07-05) x86_64 GNU/Linux

谢谢你:)

【问题讨论】:

    标签: linux bash debian webmin systemctl


    【解决方案1】:

    解决方案

    我试着这样开始

    root@vps513135:~# /etc/webmin/start
    Starting Webmin server in /usr/share/webmin
    Failed to open SSL key /home/sowdowdow/domains/sow.sowdowdow.fr/ssl.key at /usr/share/webmin/miniserv.pl line 4414.
    

    输出清楚一点,终于找到了解决办法here

    注释掉 /etc/webmin/miniserv.conf 中与 borked 服务器相关的行。

    #ipcert_sow.sowdowdow.fr,*.sow.sowdowdow.fr=/home/sowdowdow/domains/sow.sowdowdow.fr/ssl.cert
    #ipkey_sow.sowdowdow.fr,*.sow.sowdowdow.fr=/home/sowdowdow/domains/sow.sowdowdow.fr/ssl.key
    

    【讨论】:

    • 这对我有用...为了首先进入这种状态,我创建了一个启用 SSL 的虚拟服务器,它使用与主机相同的域名...砰!再也无法进入 Virtualmin/Webmin... 这真是一种享受!谢谢。
    • 如果 usermin 不想启动并且正常的服务状态方式不会产生输出,这也可以工作。改为这样做/etc/usermin/start
    【解决方案2】:

    Webmin 不支持 systemctl 命令。请使用以下命令来启动 Webmin 服务。

    /etc/rc.d/init.d/webmin stop
    systemctl start webmin
    

    我试过这个命令,我可以在我的服务器上启动 Webmin 服务。

    【讨论】:

      猜你喜欢
      • 2014-05-25
      • 1970-01-01
      • 2021-11-26
      • 1970-01-01
      • 2012-06-21
      • 2022-07-29
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      相关资源
      最近更新 更多