【问题标题】:Django with mod_wsgi on apache - 500 error: Authtype not set?在 apache 上使用 mod_wsgi 的 Django - 500 错误:未设置 Authtype?
【发布时间】:2013-08-06 12:11:54
【问题描述】:

尝试在 Dreamhost 上部署我的第一个 django 站点...我有这个工作,然后我不确定我做了什么让它停止工作。

这是错误信息:

[crit] [client 74.72.99.26] configuration error:  couldn't perform authentication. AuthType not set!: /internal_error.html

<VirtualHost :80>
WSGIScriptAlias / /home/username/mysite.com/dir/project/wsgi.py
<Directory /home/username/mysite.com/dir/project>
<Files wsgi.py>
Order deny,allow
Require all granted
</Files>
</Directory>
</VirtualHost>

我也可以包含我的 wsgi.py 信息,但我认为这不是问题,因为就像我说的那样,我的网站可以正常工作。不确定这是否相关,但我也在尝试对我的域进行密码保护(我在我的 Dreamhost 面板中这样做了),以便人们在我尝试部署它时看不到我的网站 - 这是唯一的身份验证我可以想到这可能是造成这种情况的原因,但我关闭了密码保护,但仍然出现错误。

【问题讨论】:

    标签: django apache mod-wsgi


    【解决方案1】:

    我在使用 Apache v 2.2 (Ubuntu) 时遇到了同样的问题。来自documentation:

    "如果您使用的 Apache 版本早于 2.4,请将 Require all granted 替换为 Allow from all"

    ... 并且修复了它。

    【讨论】:

    • 你真的救了我。但是在改变这个之后,我得到了这个:[error] [client 127.0.0.1] (13)Permission denied: mod_wsgi (pid=13569): Unable to connect to WSGI daemon process 'mysite.com' on '/etc/httpd/logs/wsgi.13565.0.1.sock' after multiple attempts.
    猜你喜欢
    • 2014-02-11
    • 2014-02-18
    • 2014-05-11
    • 2013-02-12
    • 2012-06-09
    • 2014-03-02
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多