【问题标题】:Cannot start tomcat on port 8080无法在端口 8080 上启动 tomcat
【发布时间】:2019-12-23 20:42:03
【问题描述】:

我已经下载了 NetBeans-8.0.1-windows 和 MySQL 5.0 安装程序和 tomcat 8.5 并成功安装在 win 7 操作系统上。

现在我正在尝试启动 Apache Tomcat,但它总是显示类似的错误

Tomcat启动失败,服务器8080端口已被占用。

请帮助解决这个问题。我已经下载了mysql-connector-java-8.0.17.zip并解压了。

【问题讨论】:

  • 帮我解决这个问题:)
  • 不用担心其他进程在使用 8080 端口,只需将 Tomcat 更改为使用不同的端口即可:[1] 使用 netstat 验证您的新端口号是否可用.例如,要验证端口 54321 是否可用,请提交 netstat -ano | findstr 54321 如果没有显示输出,则 54321 可用。如果输出返回,那么它正在使用中,所以只需选择一个不同的数字。 [2] 关于如何编辑 Tomcat 的 server.xml 以更改端口号的详细信息,请参阅How to change Tomcat default port?。
  • 请注意,只是盲目地杀死当前使用端口 8080 的进程并不一定是个好主意,除非你明白为什么要使用它。如果您不这样做,那么为 Tomcat 使用 8080 的替代端口是一种更好的方法。
  • 检查stackoverflow.com/a/48162646/3346408链接以将端口8080更改为另一个

标签: tomcat8 netbeans-8 mysql-5.0


【解决方案1】:

首先,尝试检查8080端口是否正在使用:

以管理员身份运行命令行。然后运行下面提到的命令。

netstat -ano | findstr :8080

红色圆圈区域显示 PID(进程标识符)。如果您得到类似上图的内容,请终止该端口上正在运行的进程。

然后你在识别PID后执行这个命令。

taskkill /PID <typeyourPIDhere> /F

附:再次运行第一个命令以检查该进程是否仍然可用。如果该过程成功结束,您将得到一个空行。

答案摘自以下链接:http://www.callstack.in/tech/blog/windows-kill-process-by-port-number-157

【讨论】:

  • 谢谢。我试过了,但它不起作用。当我杀死端口号 8080 时,该端口号自动再次被另一个 PID 使用。
  • 看看这个答案,它可能会帮助stackoverflow.com/a/34259707/5959252
  • 在命令行中运行“netstat -ano | findstr :8080”并获取PID后,使用任务管理器检查该端口中正在运行的服务。
  • 另一种方法是:关闭 IDE 并检查任务管理器 - 杀死所有正在运行的 javaw 进程。
  • 你试过把tomcat服务器的端口改成可用的吗?
猜你喜欢
  • 1970-01-01
  • 2020-04-20
  • 2021-05-28
  • 2021-08-23
  • 2014-04-24
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
相关资源
最近更新 更多