【发布时间】:2019-12-23 20:42:03
【问题描述】:
我已经下载了 NetBeans-8.0.1-windows 和 MySQL 5.0 安装程序和 tomcat 8.5 并成功安装在 win 7 操作系统上。
现在我正在尝试启动 Apache Tomcat,但它总是显示类似的错误
Tomcat启动失败,服务器8080端口已被占用。
请帮助解决这个问题。我已经下载了mysql-connector-java-8.0.17.zip并解压了。
【问题讨论】:
-
帮我解决这个问题:)
-
不用担心其他进程在使用 8080 端口,只需将 Tomcat 更改为使用不同的端口即可:[1] 使用 netstat 验证您的新端口号是否可用.例如,要验证端口 54321 是否可用,请提交 netstat -ano | findstr 54321 如果没有显示输出,则 54321 可用。如果输出返回,那么它正在使用中,所以只需选择一个不同的数字。 [2] 关于如何编辑 Tomcat 的 server.xml 以更改端口号的详细信息,请参阅How to change Tomcat default port?。
-
请注意,只是盲目地杀死当前使用端口 8080 的进程并不一定是个好主意,除非你明白为什么要使用它。如果您不这样做,那么为 Tomcat 使用 8080 的替代端口是一种更好的方法。
-
检查stackoverflow.com/a/48162646/3346408链接以将端口8080更改为另一个
标签: tomcat8 netbeans-8 mysql-5.0