【问题标题】:tomcat 6 won't start because of heap size由于堆大小,tomcat 6 无法启动
【发布时间】:2014-02-06 09:55:41
【问题描述】:

当我跑步时

sh catalina.sh run

报错:

最大堆大小无效:-Xmx6144M 指定的大小超过了最大可表示大小。 无法创建 Java 虚拟机。

帮助..

【问题讨论】:

  • 你试过 -Xmx1012M 吗?
  • 64 位还是 32 位机器?
  • @venergiac:32 位机器
  • 而且...这就是原因。单个 32 位进程无法访问那么多内存。
  • @Swagatika: 然后它给出Error occurred during initialization of VM Incompatible minimum and maximum heap sizes specified

标签: java linux tomcat6


【解决方案1】:

您正在运行 32 位 JVM 并且超过 4096M

或者 .. 有一种情况是 JVM 可以决定你永远不需要这么大的堆,但我从来没有遇到过。

【讨论】:

  • 我应该分配多少内存?给-Xmx2048M 也不行。 Error occurred during initialization of VM Could not reserve enough space for object heap Could not create the Java virtual machine.
  • 你是唯一能回答这个问题的人。你有多少内存?请记住,JVM 并不是机器上唯一运行的东西。
猜你喜欢
  • 2016-06-18
  • 2015-10-22
  • 2011-02-05
  • 1970-01-01
  • 2011-09-17
  • 1970-01-01
  • 2015-07-20
  • 2022-01-16
相关资源
最近更新 更多