【问题标题】:Apache (xamp) and IIS cannot work togetherApache (xampp) 和 IIS 不能一起工作
【发布时间】:2010-09-30 16:05:17
【问题描述】:

我的 PC (Windows XP SP3) 上安装了 XAMP 1.6.8 和 IIS 5.0。

我无法同时运行它们。如果 IIS 服务正在运行,Apache 会抛出以下错误:

(OS 10048)每个套接字地址(协议/网络地址/端口)通常只允许使用一次。 : make_sock: 无法绑定到地址 0.0.0.0:80 没有可用的监听套接字,正在关闭 无法打开日志 请注意上面的错误或消息,然后按 键退出。 24...

Windows 无法在本地计算机上启动 Apache2。有关详细信息,请查看系统事件日志。如果这是非 Microsoft 服务,请联系服务供应商,并参阅服务特定错误代码 1。


编辑:

Apache 在不同的端口 3128 上运行。而 IIS (asp.net) 通常在不同的端口上运行。

【问题讨论】:

  • Apache 在不同的端口上运行。

标签: apache iis apache2 xampp


【解决方案1】:

如果你不能击中圆圈中心的箭头,请击中箭头,然后在它周围画一个圆圈。 - 我尝试了所有建议,卸载了Skype,没有运行IIS,将apache程序添加到杀毒软件中,仍然没有解决程序

最后我将 apaches 端口从 80 更改为 82 在 httpd.conf 中查找 Listen 80 并更改此

【讨论】:

    【解决方案2】:

    您需要配置 Apache 或 IIS 以侦听不同的端口。

    您还可以使用tcpview 来检查哪些应用程序正在使用哪些端口,因为这听起来像是有冲突。

    【讨论】:

    • 你没有正确设置它 - 它给出的错误是它无法监听端口 80。它可能正在监听 3128,但它也在尝试监听 80。
    【解决方案3】:

    "could not bind to address 0.0.0.0:80" 意味着,当它启动时,它会尝试绑定到所有可用网络接口上的端口 80。由于 IIS 已经占用了一个(或多个)要绑定的 IP,因此 apache 无法获取任何 IP,因此会失败。

    (如果您已将其配置为绑定到所有 IP,我不确定它是否会绑定到任何可用的 IP,但已经占用了一个。)

    因此,请将 Apache 配置为绑定到不同的端口(如果您只有 1 个 IP 地址),或者绑定到不同的 IP 或 IP 范围。

    您通过changing the binding 执行此操作。首先在配置文件(httpd.conf)中找到Listen指令并进行更改。目前它会说"Listen 80"(表示所有IP),将其更改为“Listen 192.168.0.2:80”以使其绑定到指定的IP地址。

    您可能还必须编辑 IIS 配置以告诉它也只绑定到单个 IP 地址。

    【讨论】:

      猜你喜欢
      • 2015-11-24
      • 1970-01-01
      • 2015-11-23
      • 2018-04-14
      • 2011-07-29
      • 1970-01-01
      • 2013-12-11
      • 2013-12-12
      • 1970-01-01
      相关资源
      最近更新 更多