【发布时间】:2013-01-19 20:49:28
【问题描述】:
我知道有人回答了类似的问题,但请尝试帮助我。
我正在使用 PHPMyAdmin 将 MyBB 数据库的备份导入到新主机中。尝试导入 .sql 文件时,出现以下错误:
SQL 查询:
INSERT INTO mybb_datacache( `title` , `cache` )
VALUES (
'internal_settings', 'a:1:{s:14:\"encryption_key\";s:32:\"rrvohvVATtOauucNTmEXAmvNvbw9ujvb\";}'
);
MySQL said:
#1062 - Duplicate entry 'internal_settings' for key 'PRIMARY'
我无法找出问题所在。我已经清空了所有表并全新安装了四次数据库。我整天都在想办法解决这个问题,这非常令人沮丧。
(链接已删除)
请帮帮我。我该如何解决这个问题?
【问题讨论】:
-
您需要从托管该文件的位置提取该文件。我猜您不知道该文件中的内容,但为了您的工作以及您正在帮助的任何公司/网站,请立即删除该文件!
-
为什么标题中的错误信息与问题正文中的错误信息不同?
-
标题中提到的特定消息的可能原因是主键列的类型错误:当应该是字符串时设置为数字。
-
@Jaxidian 对不起。沮丧,甚至没有意识到我刚刚做了什么。
标签: mysql sql database phpmyadmin