【问题标题】:406 Not acceptable error getting godaddy server406 获取 Godaddy 服务器时出现不可接受的错误
【发布时间】:2015-10-15 10:43:54
【问题描述】:
我遇到了一个大问题,突然我的服务器响应“406 Not Acceptable”错误。
POST 在我的服务器上不起作用。
我尝试使用更多脚本来解决此问题。
我使用了.HTACCESS 脚本
<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>
但问题没有解决。其他的看不懂,想联系godaddy,但是没有联系方式,直播很差,老说他们流量很大。
请您对此提供一些适当的解决方案?
【问题讨论】:
标签:
.htaccess
server
cpanel
【解决方案1】:
错误 406 错误的主要原因是服务器上的 mod_security 规则。 Mod_security 是 Apache Web 服务器中的一个安全模块,默认情况下在所有主机帐户上启用。
如果任何网站、页面或任何功能违反这些规则之一,服务器可能会发送 406 Not Acceptable 错误。大多数情况下,当您的代码中有任何不安全性时,就会触发此错误。您可以解决代码中的不安全问题,也可以关闭 mod_security。关闭 mod_security 可能会打开该潜在的不安全页面,从而对您的网站进行恶意攻击。所以最好调查它并修复你的代码。
如果您有 WHM 访问权限,请检查您的 mod 安全日志文件。它将向您显示导致此错误的确切原因。您可以在
找到审核日志
/usr/local/apache/logs/audit_log
和模式安全配置文件位于
/usr/local/apache/conf/modsec.conf
/usr/local/apache/conf/modsec.user.conf