【问题标题】:PHP warning getimagesize [duplicate]PHP警告getimagesize [重复]
【发布时间】:2012-05-06 11:14:09
【问题描述】:

我在尝试将图像上传到服务器时遇到这些错误

警告:getimagesize(../images/image-1Product 320120312100APPLE_IMG_0072.jpg) [function.getimagesize]:无法打开流:/home/content/44/8713044/html/admin/Home 中没有这样的文件或目录.php 在第 107 行

警告:imagecreatefromjpeg(../images/image-1Product 320120312100APPLE_IMG_0072.jpg) [function.imagecreatefromjpeg]:无法打开流:/home/content/44/8713044/html/admin/Home 中没有这样的文件或目录.php 在第 122 行

警告:imagecopyresampled():提供的参数不是第 128 行 /home/content/44/8713044/html/admin/Home.php 中的有效图像资源

我知道为什么我会因为第一个和第二个错误而收到第三个错误,但我不知道为什么我会收到 1 和 2 的警告,该文件夹确实存在。

第 107 行 - $size = getimagesize($source);

第 122 行 - $image = imagecreatefromjpeg($source);

第 128 行 - imagecopyresampled($new_image,$image,0,0,$x,$y,$thumb_width,$thumb_width,$width,$height);

如果有人有任何提示,将不胜感激。

我将其更改为完整路径,但收到此错误URL file-access is disabled in the server configuration

【问题讨论】:

  • 你确定路径正确吗?
  • 你的相对路径真的正确吗?尝试绝对路径(对不起我的英语)
  • 尝试使用图像的绝对路径而不是相对路径。
  • 是什么让你相信有这些名字的文件?

标签: php warnings


【解决方案1】:

这个问题通常通过重新配置php.ini来解决

allow_url_fopen = On

为此,您可能需要联系您的托管服务提供商。

如果您使用的是 Wordpress 或任何其他 CMS,则可能会由于安装了安全插件而导致错误。 大多数安全插件都会更改 .htaccess 以防止未经授权访问 url、目录和文件。

检查您的 .htaccess 并搜索

RewriteRule ^.* - [F,L]

如果您找到它,请将其删除 (#RewriteRule ^.* - [F,L]) 并检查它是否解决了您的问题。

【讨论】:

  • 通过删除它,我得到 500 个内部服务器错误 :( 再次输入这些值再次显示 500 个内部服务器。可能是什么原因?非常感谢任何帮助。
【解决方案2】:

您的 $source 变量指向错误的路径..
如果您在包含此代码的其他文件夹中包含一个 php 文件,请尝试使用这样的本地路径:

$source='images/image-1Product 320120312100APPLE_IMG_0072.jpg';
$size = getimagesize($source);

如果您的图像文件夹位于根目录中,则不要使用“../”,即第一个文件在那里。

【讨论】:

  • 如果 images 文件夹不在根目录下,它在服务器上,但不在根目录下
  • ex:您的 www 文件夹包含另外两个文件夹,例如 1-images 2-includes 和您的 index.php 。如果 index.php 在“includes”文件夹中包含一个文件,则您不能使用“../images”访问该文件上的图像文件夹。因为您将要处理的第一个文件是 index.php。也许这是您的错误.我确定您的 $source 指向错误的路径。
  • root/images & root/upload 是我要上传到的文件夹...正在上传的文件是root/admin/home.php
  • 哪个文件包含 $source 以及在哪个文件夹中?您是否使用直接网址,例如:“site.com/admin/home.php”?
【解决方案3】:

尝试删除文件名中的空格。我曾经遇到过这样的问题,我相信删除空间可以解决它。

变化:

image-1Product 320120312100APPLE_IMG_0072.jpg)

收件人:

image-1Product320120312100APPLE_IMG_0072.jpg)

【讨论】:

    【解决方案4】:
    1. 尝试输入完整的url来路由到图片意思包括http://
    2. 检查您对文件夹的权利含义:权利 777

    【讨论】:

    • 当我尝试使用完整路径URL file-access is disabled in the server configuration时出现此错误
    猜你喜欢
    • 2014-01-31
    • 1970-01-01
    • 2013-07-10
    • 1970-01-01
    • 2013-03-19
    • 2012-10-05
    • 2015-01-21
    • 2018-09-13
    • 2012-02-08
    相关资源
    最近更新 更多