【问题标题】:Connection refused to PostgreSQL server连接到 PostgreSQL 服务器被拒绝
【发布时间】:2014-08-30 11:33:41
【问题描述】:

我目前正在我的 Windows 计算机上设置 postreSQL 服务器。

我想创建我的第一个数据库,但由于密码验证失败而无法创建 createdb 函数。因此我在这个网站上发现了以下问题:

How to configure postgresql for the first time?

但是,我想我忘记了 ;在结尾:

ALTER USER postgres with encrypted password 'xxxxxxx';

现在,当我尝试启动 psql 时,出现以下错误:

Server [localhost]:
Database [postgres]:
Port [5432]:
Username [postgres]:
Active code page: 1252
psql: could not connect to server: Connection refused (0x0000274D/10061)
    Is the server running on host "localhost" (::1) and accepting
    TCP/IP connections on port 5432?
could not connect to server: Connection refused (0x0000274D/10061)
    Is the server running on host "localhost" (127.0.0.1) and accepting
    TCP/IP connections on port 5432?
Press any key to continue . . .

知道我可以做些什么来解决这个问题吗?

您认为真的是缺少半列导致问题吗?

您有关于如何在 Windows 上设置 postgreSQL 数据库的教程吗?到目前为止,我发现的所有版本都仅适用于 Linux。

【问题讨论】:

    标签: database windows postgresql configuration postgresql-9.3


    【解决方案1】:

    您遇到的错误似乎来自当前未运行的 Postgres,而不是您推测的身份验证错误。 PSQL 客户端或您正在使用的任何 PG 客户端正在尝试在默认端口上建立连接,但没有任何内容。

    如果 Postgres 当前没有运行,请尝试查找它(通过 CTRL-Alt-Delete)。如果它正在运行,请尝试终止它并重新启动它。希望能解决问题...否则您的端口 5432 可能由于某种原因被阻止。

    如果全部失败,我仍然怀疑括号是否会导致此错误,因为它不是身份验证错误。尝试使用全新安装重新安装 Postgres。

    【讨论】:

    • 您好,感谢您的回答。我重新启动了我的电脑几次,但它并没有解决问题。删除所有配置文件后卸载并重新安装解决了问题,即使我更愿意找到更好的方法。
    • 配置文件可能有一些错误的参数(可能是错误的端口号或注释掉的部分)。很高兴它成功了
    • 嗨,我在同一台机器上有 postgres 9.3、9.6 和 10。我的电脑死机了,我用硬重置重新启动了电脑,你也遇到了同样的问题。 Postgres 9.6 和 10 的服务无法启动。因此,我将 Postgre 9.3 的工作 pg_hba.conf 复制到 9.6 和 10 的文件夹中,并重新启动服务并连接到数据库。
    猜你喜欢
    • 2013-05-19
    • 1970-01-01
    • 2020-08-19
    • 2017-04-28
    • 1970-01-01
    • 2011-12-29
    • 1970-01-01
    • 1970-01-01
    • 2023-03-17
    相关资源
    最近更新 更多