【问题标题】:Windows MySQL console issueWindows MySQL 控制台问题
【发布时间】:2015-07-14 18:40:22
【问题描述】:

我在 MySQL 日志中收到此错误。什么意思?

2015-05-05 14:31:41 2620 [Note] Plugin 'FEDERATED' is disabled.
2015-05-05 14:31:41 2620 [Note] InnoDB: Using atomics to ref count buffer pool pages
2015-05-05 14:31:41 2620 [Note] InnoDB: The InnoDB memory heap is disabled
2015-05-05 14:31:41 2620 [Note] InnoDB: `enter code here`Mutexes and rw_locks use Windows interlocked functions
2015-05-05 14:31:41 2620 [Note] InnoDB: Compressed tables use zlib 1.2.3
2015-05-05 14:31:41 2620 [Note] InnoDB: Not using CPU crc32 instructions
2015-05-05 14:31:41 2620 [Note] InnoDB: Initializing buffer pool, size = 128.0M
2015-05-05 14:31:41 2620 [Note] InnoDB: Completed initialization of buffer pool
2015-05-05 14:31:41 2620 [Note] InnoDB: Highest supported file format is Barracuda.
2015-05-05 14:31:41 2620 [Note] InnoDB: 128 rollback segment(s) are active.
2015-05-05 14:31:41 2620 [Note] InnoDB: Waiting for purge to start
2015-05-05 14:31:41 2620 [Note] InnoDB: 5.6.17 started; log sequence number 1626223
2015-05-05 14:31:41 2620 [Note] Server hostname (bind-address): '*'; port: 3306
2015-05-05 14:31:41 2620 [Note] IPv6 is available.
2015-05-05 14:31:41 2620 [Note]   - '::' resolves to '::';
2015-05-05 14:31:41 2620 [Note] Server socket created on IP: '::'.
2015-05-05 14:31:41 2620 [ERROR] Can't start server: Bind on TCP/IP port: No such file or directory
2015-05-05 14:31:41 2620 [ERROR] Do you already have another mysqld server running on port: 3306 ?
2015-05-05 14:31:41 2620 [ERROR] Aborting

2015-05-05 14:31:41 2620 [Note] Binlog end
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'partition'
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'PERFORMANCE_SCHEMA'
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'INNODB_SYS_DATAFILES'
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'INNODB_SYS_TABLESPACES'
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'INNODB_SYS_FOREIGN_COLS'
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'INNODB_SYS_FOREIGN'
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'INNODB_SYS_FIELDS'
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'INNODB_SYS_COLUMNS'
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'INNODB_SYS_INDEXES'
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'INNODB_SYS_TABLESTATS'
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'INNODB_SYS_TABLES'
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'INNODB_FT_INDEX_TABLE'
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'INNODB_FT_INDEX_CACHE'
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'INNODB_FT_CONFIG'
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'INNODB_FT_BEING_DELETED'
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'INNODB_FT_DELETED'
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'INNODB_FT_DEFAULT_STOPWORD'
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'INNODB_METRICS'
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'INNODB_BUFFER_POOL_STATS'
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'INNODB_BUFFER_PAGE_LRU'
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'INNODB_BUFFER_PAGE'
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'INNODB_CMP_PER_INDEX_RESET'
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'INNODB_CMP_PER_INDEX'
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'INNODB_CMPMEM_RESET'
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'INNODB_CMPMEM'
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'INNODB_CMP_RESET'
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'INNODB_CMP'
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'INNODB_LOCK_WAITS'
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'INNODB_LOCKS'
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'INNODB_TRX'
2015-05-05 14:31:41 2620 [Note] Shutting down plugin 'InnoDB'
2015-05-05 14:31:41 2620 [Note] InnoDB: FTS optimize thread exiting.
2015-05-05 14:31:41 2620 [Note] InnoDB: Starting shutdown...
2015-05-05 14:31:43 2620 [Note] InnoDB: Shutdown completed; log sequence number 1626233
2015-05-05 14:31:43 2620 [Note] Shutting down plugin 'BLACKHOLE'
2015-05-05 14:31:43 2620 [Note] Shutting down plugin 'ARCHIVE'
2015-05-05 14:31:43 2620 [Note] Shutting down plugin 'MRG_MYISAM'
2015-05-05 14:31:43 2620 [Note] Shutting down plugin 'MyISAM'
2015-05-05 14:31:43 2620 [Note] Shutting down plugin 'MEMORY'
2015-05-05 14:31:43 2620 [Note] Shutting down plugin 'CSV'
2015-05-05 14:31:43 2620 [Note] Shutting down plugin 'sha256_password'
2015-05-05 14:31:43 2620 [Note] Shutting down plugin 'mysql_old_password'
2015-05-05 14:31:43 2620 [Note] Shutting down plugin 'mysql_native_password'
2015-05-05 14:31:43 2620 [Note] Shutting down plugin 'binlog'
2015-05-05 14:31:43 2620 [Note] wampmysqld: Arrêt du serveur terminé

我遵循了此处提供的修复:

http://dev.mysql.com/doc/mysql-windows-excerpt/5.0/en/resetting-permissions-windows.html

但这对我不起作用。这是为什么呢?

【问题讨论】:

    标签: mysql phpmyadmin wamp wampserver


    【解决方案1】:

    这只是一个猜测,但错误日志中的这些行让我认为您的 PC 上正在运行另一台 MySQL 服务器,并且它已经占用了 3306 端口。

    [ERROR] Can't start server: Bind on TCP/IP port: No such file or directory
    [ERROR] Do you already have another mysqld server running on port: 3306 ?
    

    查看服务管理单元

    windows key + R
    Keyin services.msc
    Press OK button
    

    如果您安装了 64 位 WAMPServer,则 WAMPServer 的 MySQL 服务器实例称为 wampmysqld 或 wampmysqld64。

    如果另一个 MySQL 实例正在运行,它可能被称为 MYSQL。如果您看到其中一个已经运行了 MySQL 服务器。

    找出原因。

    如果您不再需要该其他实例,请将其卸载。

    请记住备份您认为可能仍需要迁移到 WAMPServer 的 MySQL 服务器的任何数据库。

    您的 PC 上肯定只需要一个 MySQL。

    或者,您可以将 MYSQL 服务的 Startup Type 更改为已禁用。然后,如果您以后发现需要它来做某事,您可以返回并重新启用它。

    禁用其他服务将允许 WAMPServer 的 MySQL 启动。

    【讨论】:

      猜你喜欢
      • 1970-01-01
      • 2011-06-11
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 2020-03-10
      • 2010-09-27
      相关资源
      最近更新 更多