【问题标题】:IBM MobileFirst 7.0 Server : No runtime environment deployed in this serverIBM MobileFirst 7.0 服务器:此服务器中未部署运行时环境
【发布时间】:2015-08-14 10:07:11
【问题描述】:

在以下环境中成功安装了IBM MobileFirst 7.0 Server,并且一步步创建了运行环境,并在该服务器中部署了successfully(MobileFirst Platform Configurion Tool的GUI显示部署):

  • CentOS 6.4
  • MobileFirst Server 7.0
  • jdk-7u79
  • MySQL 5.6.24
  • Apache Tomcat 7.0.62

但我从 worklightconsole 收到了No runtime environment deployed in this server。

我找不到任何显示错误消息的日志。另外,在MySQL数据库中自动创建了WL相关表,Tomcat路径中也生成了Worklight相关文件夹。

MobileFirst Platform Configurion Tool 的 GUI 显示 deployed:

【问题讨论】:

  • 在您的 Tomcat 日志文件夹中找到 messages.log。提供它。
  • @IdanAdar 你的意思是 catalina.2015-06-01.log 或 localhost.2015-06-01.log ?
  • 我的意思是我认为的 systemout.log
  • @IdanAdar 上传了整个tomcat\logs 文件夹。 dropbox.com/sh/w33ndt7tf9hjtac/AABDfpsScrvCFBwh07-4YIKWa?dl=0
  • @IdanAdar systemout.log 在任何日志文件夹中都找不到...

标签: ibm-mobilefirst mobilefirst-server


【解决方案1】:

失败的原因可能是由于 ssoExpiredLoginContextsCleanupTask 错误导致服务器无法加载:

原因:org.apache.openjpa.lib.jdbc.ReportingSQLException:不能 执行语句:无法写入二进制日志,因为 BINLOG_FORMAT = STATEMENT 并且至少一个表使用存储引擎 仅限于基于行的日志记录。 InnoDB 仅限于行日志记录 事务隔离级别是 READ COMMITTED 或 READ UNCOMMITTED。 {prepstmnt 1015602967 插入到 CLUSTER_SYNC(ID,hostVmId, updateTimestamp,版本)值(?,?,?,?)[参数=(字符串) ssoExpiredLoginContextsCleanupTask, (null) null, (long) 0, (long) 0]} [代码=1665,状态=HY000]

要更正它,建议按照以下说明进行操作:http://www-01.ibm.com/support/docview.wss?uid=swg21695572,这也与 MFP Server(而不仅仅是 Application Center Server)相关。

【讨论】:

  • 谢谢你,伙计。最后通过使用另一个 MySQL 服务器解决了这个问题。
猜你喜欢
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 2023-03-14
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
相关资源
最近更新 更多