【发布时间】:2015-03-24 08:57:40
【问题描述】:
我的设置:
site1.com | 80 端口
site2.com | 80 端口
panel.site1.com |将端口 80 流量重写为 443
这一直有效,直到有人尝试 https://site[x].com 并且服务器将他们重定向到我的面板。我需要这个面板对大约 100 名将使用它的人开放,但我不希望错误的人偶然发现它。
我已经尝试添加:
<VirtualHost *:443>
ServerAdmin me@email
ServerName site1.com
ServerAlias www.site1.com
RewriteEngine On
RewriteCond %{HTTPS} on
RewriteRule (.*) http://%{HTTP_HOST}%{REQUEST_URI}
</VirtualHost>
到 site1.com 的虚拟主机,但它仍然返回控制面板。我相信这是因为在应用 Apache vhost 规则之前检查了证书,但我不太确定。是否有解决此问题的方法,或者仅仅是 Apache2+SSL 的限制?
【问题讨论】: