【问题标题】:MySQL won't start [closed]MySQL不会启动[关闭]
【发布时间】:2012-05-21 13:09:57
【问题描述】:

当我尝试启动 MySQL 时,我得到:

ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)

当我使用 sudo 时,我得到:

Starting MySQL
. ERROR! The server quit without updating PID file (/usr/local/var/mysql/Victorias-MacBook-Pro.local.pid).

我正在使用 Mac OS X 10.7。我通过自制软件安装了 MySQL,并安装了 MySQL 5.5.20。

这是我得到的 .err 文件:

120513 22:30:03 mysqld_safe Starting mysqld daemon with databases from /usr/local/var/mysql
120513 22:30:03 [Warning] Setting lower_case_table_names=2 because file system for /usr/local/var/mysql/ is case insensitive
/usr/local/Cellar/mysql/5.5.20/bin/mysqld: Table 'mysql.plugin' doesn't exist
120513 22:30:03 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
120513 22:30:03 InnoDB: The InnoDB memory heap is disabled
120513 22:30:03 InnoDB: Mutexes and rw_locks use GCC atomic builtins
120513 22:30:03 InnoDB: Compressed tables use zlib 1.2.5
120513 22:30:03 InnoDB: Initializing buffer pool, size = 128.0M
120513 22:30:03 InnoDB: Completed initialization of buffer pool
120513 22:30:03 InnoDB: highest supported file format is Barracuda.
120513 22:30:03  InnoDB: Waiting for the background threads to start
120513 22:30:04 InnoDB: 1.1.8 started; log sequence number 1595675
120513 22:30:04 [ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.host' doesn't exist
120513 22:30:04 mysqld_safe mysqld from pid file /usr/local/var/mysql/Victorias-MacBook-Pro.local.pid ended
120513 22:30:13 mysqld_safe Starting mysqld daemon with databases from /usr/local/var/mysql
120513 22:30:13 [Warning] Setting lower_case_table_names=2 because file system for /usr/local/var/mysql/ is case insensitive
/usr/local/Cellar/mysql/5.5.20/bin/mysqld: Table 'mysql.plugin' doesn't exist
120513 22:30:13 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
120513 22:30:13 InnoDB: The InnoDB memory heap is disabled
120513 22:30:13 InnoDB: Mutexes and rw_locks use GCC atomic builtins
120513 22:30:13 InnoDB: Compressed tables use zlib 1.2.5
120513 22:30:13 InnoDB: Initializing buffer pool, size = 128.0M
120513 22:30:13 InnoDB: Completed initialization of buffer pool
120513 22:30:13 InnoDB: highest supported file format is Barracuda.
120513 22:30:13  InnoDB: Waiting for the background threads to start
120513 22:30:14 InnoDB: 1.1.8 started; log sequence number 1595675
120513 22:30:14 [ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.host' doesn't exist
120513 22:30:14 mysqld_safe mysqld from pid file /usr/local/var/mysql/Victorias-MacBook-Pro.local.pid ended
120513 22:30:24 mysqld_safe Starting mysqld daemon with databases from /usr/local/var/mysql
120513 22:30:24 [Warning] Setting lower_case_table_names=2 because file system for /usr/local/var/mysql/ is case insensitive
/usr/local/Cellar/mysql/5.5.20/bin/mysqld: Table 'mysql.plugin' doesn't exist
120513 22:30:24 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
120513 22:30:24 InnoDB: The InnoDB memory heap is disabled
120513 22:30:24 InnoDB: Mutexes and rw_locks use GCC atomic builtins
120513 22:30:24 InnoDB: Compressed tables use zlib 1.2.5
120513 22:30:24 InnoDB: Initializing buffer pool, size = 128.0M
120513 22:30:24 InnoDB: Completed initialization of buffer pool
120513 22:30:24 InnoDB: highest supported file format is Barracuda.
120513 22:30:24  InnoDB: Waiting for the background threads to start
120513 22:30:25 InnoDB: 1.1.8 started; log sequence number 1595675
120513 22:30:25 [ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.host' doesn't exist
120513 22:30:25 mysqld_safe mysqld from pid file /usr/local/var/mysql/Victorias-MacBook-Pro.local.pid ended
120513 22:30:34 mysqld_safe Starting mysqld daemon with databases from /usr/local/var/mysql
120513 22:30:34 [Warning] Setting lower_case_table_names=2 because file system for /usr/local/var/mysql/ is case insensitive
/usr/local/Cellar/mysql/5.5.20/bin/mysqld: Table 'mysql.plugin' doesn't exist
120513 22:30:34 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
120513 22:30:34 InnoDB: The InnoDB memory heap is disabled
120513 22:30:34 InnoDB: Mutexes and rw_locks use GCC atomic builtins
120513 22:30:34 InnoDB: Compressed tables use zlib 1.2.5
120513 22:30:34 InnoDB: Initializing buffer pool, size = 128.0M
120513 22:30:34 InnoDB: Completed initialization of buffer pool
120513 22:30:34 InnoDB: highest supported file format is Barracuda.
120513 22:30:34  InnoDB: Waiting for the background threads to start
120513 22:30:35 InnoDB: 1.1.8 started; log sequence number 1595675
120513 22:30:35 [ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.host' doesn't exist
120513 22:30:35 mysqld_safe mysqld from pid file /usr/local/var/mysql/Victorias-MacBook-Pro.local.pid ended
120513 22:30:44 mysqld_safe Starting mysqld daemon with databases from /usr/local/var/mysql
120513 22:30:44 [Warning] Setting lower_case_table_names=2 because file system for /usr/local/var/mysql/ is case insensitive
/usr/local/Cellar/mysql/5.5.20/bin/mysqld: Table 'mysql.plugin' doesn't exist
120513 22:30:44 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
120513 22:30:44 InnoDB: The InnoDB memory heap is disabled
120513 22:30:44 InnoDB: Mutexes and rw_locks use GCC atomic builtins
120513 22:30:44 InnoDB: Compressed tables use zlib 1.2.5
120513 22:30:44 InnoDB: Initializing buffer pool, size = 128.0M
120513 22:30:44 InnoDB: Completed initialization of buffer pool
120513 22:30:44 InnoDB: highest supported file format is Barracuda.
120513 22:30:44  InnoDB: Waiting for the background threads to start
120513 22:30:45 InnoDB: 1.1.8 started; log sequence number 1595675
120513 22:30:45 [ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.host' doesn't exist
120513 22:30:45 mysqld_safe mysqld from pid file /usr/local/var/mysql/Victorias-MacBook-Pro.local.pid ended
120513 22:30:54 mysqld_safe Starting mysqld daemon with databases from /usr/local/var/mysql
120513 22:30:54 [Warning] Setting lower_case_table_names=2 because file system for /usr/local/var/mysql/ is case insensitive
/usr/local/Cellar/mysql/5.5.20/bin/mysqld: Table 'mysql.plugin' doesn't exist
120513 22:30:54 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
120513 22:30:54 InnoDB: The InnoDB memory heap is disabled
120513 22:30:54 InnoDB: Mutexes and rw_locks use GCC atomic builtins
120513 22:30:54 InnoDB: Compressed tables use zlib 1.2.5
120513 22:30:54 InnoDB: Initializing buffer pool, size = 128.0M
120513 22:30:54 InnoDB: Completed initialization of buffer pool
120513 22:30:54 InnoDB: highest supported file format is Barracuda.
120513 22:30:54  InnoDB: Waiting for the background threads to start
120513 22:30:55 InnoDB: 1.1.8 started; log sequence number 1595675
120513 22:30:55 [ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.host' doesn't exist
120513 22:30:55 mysqld_safe mysqld from pid file /usr/local/var/mysql/Victorias-MacBook-Pro.local.pid ended
120513 22:31:04 mysqld_safe Starting mysqld daemon with databases from /usr/local/var/mysql
120513 22:31:04 [Warning] Setting lower_case_table_names=2 because file system for /usr/local/var/mysql/ is case insensitive
/usr/local/Cellar/mysql/5.5.20/bin/mysqld: Table 'mysql.plugin' doesn't exist
120513 22:31:04 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
120513 22:31:04 InnoDB: The InnoDB memory heap is disabled
120513 22:31:04 InnoDB: Mutexes and rw_locks use GCC atomic builtins
120513 22:31:04 InnoDB: Compressed tables use zlib 1.2.5
120513 22:31:04 InnoDB: Initializing buffer pool, size = 128.0M
120513 22:31:04 InnoDB: Completed initialization of buffer pool
120513 22:31:04 InnoDB: highest supported file format is Barracuda.
120513 22:31:04  InnoDB: Waiting for the background threads to start

【问题讨论】:

  • 您能否添加更多与您尝试启动 mysql 的环境相关的信息?

标签: mysql


【解决方案1】:

删除此 pid 文件,确保所有实例都已停止(杀死任何未关闭的进程),检查没有正在侦听 MySQL 端口 3306(netstat 应该有帮助)并尝试再次启动 MySQL。

【讨论】:

  • 我得到同样的错误,但我没有看到任何 pid 文件..
  • 杀死任何正在运行的mysqld进程的简单方法是转到活动监视器并搜索它,然后点击退出。为我工作。
猜你喜欢
  • 1970-01-01
  • 2012-02-12
  • 2015-11-01
  • 2017-11-18
  • 2021-12-29
  • 2017-06-26
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
相关资源
最近更新 更多