【问题标题】:How to fix startup error in MySQL in XAMPP?如何修复 XAMPP 中 MySQL 的启动错误?
【发布时间】:2021-12-19 23:21:39
【问题描述】:

当我运行 XAMPP 和 MySQL 时,它给出“MySQL 意外关闭”,我查看了其他问题,但它们有不同的错误日志,这是我的错误日志。我尝试更改备份文件夹并将端口更改为 3307,但似乎没有任何作用。谢谢

2021-11-05 19:20:37 0 [ERROR] Do you already have another mysqld server running on port: 3306 ?
2021-11-05 19:20:37 0 [ERROR] Aborting
2021-11-05 19:25:01 0 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2021-11-05 19:25:01 0 [Note] InnoDB: Uses event mutexes
2021-11-05 19:25:01 0 [Note] InnoDB: Compressed tables use zlib 1.2.11
2021-11-05 19:25:01 0 [Note] InnoDB: Number of pools: 1
2021-11-05 19:25:01 0 [Note] InnoDB: Using SSE2 crc32 instructions
2021-11-05 19:25:01 0 [Note] InnoDB: Initializing buffer pool, total size = 16M, instances = 1, chunk size = 16M
2021-11-05 19:25:01 0 [Note] InnoDB: The log sequence number 300342 in the system tablespace does not match the log sequence number 300360 in the ib_logfiles!
2021-11-05 19:25:02 0 [Note] InnoDB: 128 out of 128 rollback segments are active.
2021-11-05 19:25:02 0 [Note] InnoDB: Creating shared tablespace for temporary tables
2021-11-05 19:25:02 0 [Note] InnoDB: Setting file '\xampp\mysql\data\ibtmp1' size to 12 MB. Physically writing the file full; Please wait ...
2021-11-05 19:25:02 0 [Note] InnoDB: File '\xampp\mysql\data\ibtmp1' size is now 12 MB.
2021-11-05 19:25:02 0 [Note] InnoDB: Waiting for purge to start
2021-11-05 19:25:02 0 [Note] InnoDB: 10.4.21 started; log sequence number 300360; transaction id 170
2021-11-05 19:25:02 0 [Note] InnoDB: Loading buffer pool(s) from C:\xampp\mysql\data\ib_buffer_pool
2021-11-05 19:25:02 0 [Note] Plugin 'FEEDBACK' is disabled.
2021-11-05 19:25:02 0 [Note] Server socket created on IP: '::'.
2021-11-05 19:25:02 0 [ERROR] Can't start server: Bind on TCP/IP port. Got error: 10048: Only one usage of each socket address (protocol/network address/port) is normally permitted.

【问题讨论】:

  • 当你运行 MySQL 时,MySQL 是否已经从另一个启动进程运行?这似乎很可能,因为某些东西已经在使用 TCP3306。尝试连接到 localhost 3306。
  • 如何连接到 localhost 3306?

标签: mysql xampp


【解决方案1】:

MySQL在后台运行,进入任务管理器,找到正在运行的进程,点击结束任务,然后重试。 MySQL 没有启动,因为它在后台运行。

【讨论】:

    猜你喜欢
    • 2018-01-24
    • 2019-09-03
    • 2020-04-24
    • 2019-09-16
    • 2021-05-18
    • 1970-01-01
    • 2017-04-11
    • 1970-01-01
    • 2019-05-06
    相关资源
    最近更新 更多