【问题标题】:Laravel application displays only white page on live serverLaravel 应用程序仅在实时服务器上显示白页
【发布时间】:2015-08-04 16:40:12
【问题描述】:

我已经使用 Laravel 4.2 提出了申请。它在 Wamp 上运行良好,但是当我将它上传到共享主机时,它只显示一个空白页面。我遵循了以下链接中给出的所有建议,但仍然无法正常工作。

Uploading Laravel Project onto Web Server

Avoid public folder of laravel and open directly the root in web server

我刚刚意识到 laravel 4.2 需要 php 5.4 或更高版本,但我的主机使用 php 5.3.28。这可能是问题的原因吗?如果没有,那我只得到空白页的原因是什么?

【问题讨论】:

    标签: php laravel


    【解决方案1】:

    是的——在没有所需版本的 PHP 的情况下使用 Laravel 绝对会给您带来问题。您必须升级您的网络服务器或询问您的主机是否可以为您升级或启用更新版本的 PHP。

    【讨论】:

      【解决方案2】:

      很遗憾,当 PHP 代码出现错误时,只有一个空白页。

      试着把它放在那里

      error_reporting(E_ALL);

      【讨论】:

        【解决方案3】:

        授予存储文件夹的权限。 chmod -R 0777 app/storage

        【讨论】:

        • 无论您希望完成什么,chmod 777 都是错误和不安全的。生产服务器,回滚并恢复正常权限(对于您的用例,可能是 755 或 775),并检查此错误配置是否已被入侵者用于提升权限和/或促进基础架构内的横向移动。在最坏的情况下,擦除服务器并从已知良好的备份中恢复。
        【解决方案4】:

        运行命令

        php  artisan key:generate
        

        我的问题解决了

        【讨论】:

        • 你能解释一下吗?
        • 我遇到了同样的问题,然后我通过运行上面提到的命令重新创建了我的应用程序密钥,然后一切都很好了
        猜你喜欢
        • 2020-11-29
        • 2020-10-04
        • 2016-04-06
        • 2020-10-26
        • 1970-01-01
        • 1970-01-01
        • 2022-08-19
        • 1970-01-01
        • 2021-12-26
        相关资源
        最近更新 更多