【发布时间】:2015-09-23 05:42:14
【问题描述】:
尝试启动 XAMPP 时出现以下错误:
12:34:26 PM [mysql] Attempting to start MySQL service...
12:34:38 PM [mysql] Problem detected!
12:34:38 PM [mysql] Port 3306 in use by ""C:\Program Files\MySQL\MySQL Server 5.1\bin\mysqld" --defaults-file="C:\Program Files\MySQL\MySQL Server 5.1\my.ini" MySQL"!
12:34:38 PM [mysql] MySQL WILL NOT start without the configured ports free!
12:34:38 PM [mysql] You need to uninstall/disable/reconfigure the blocking application
12:34:38 PM [mysql] or reconfigure MySQL and the Control Panel to listen on a different port
12:34:38 PM [mysql] Attempting to start MySQL service...
【问题讨论】:
-
错误对我来说很清楚,清除端口 3306 或让 MySQL 在不同的端口上运行。
-
当另一个 MySQL 已经在机器上运行(使用相同的端口)时,您似乎正在尝试启动 MySQL。