【问题标题】:how to install zend framework 2 on my shared hosting server如何在我的共享主机服务器上安装 zend 框架 2
【发布时间】:2015-01-08 08:29:18
【问题描述】:

我正在我的共享主机服务器上安装 zend 框架 2。到目前为止,我执行了以下步骤。

  1. 下载了ZF2骨架应用,上传到我的public_html。目前,我的服务器上的“public_html”文件夹中有 config、data、module、public、vendor 和 init_autoloader.php。

  2. 下载完整包 (ZendFramework-1.12.9) 并复制“library”文件夹并将其放在 public_html/vender/ZF2/ 下,以便在 init_autoloader.php 中运行

  3. 创建了我在下面输入的 .htaccess:

    重写引擎开启
    重写基础 /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule !.(js|ico|txt|gif|jpg|png|css)$ index.php

  4. 创建 index.php 并将其放在 public_html/ 下。内容如下:

    <?php 
    define('RUNNING_FROM_ROOT', true);
    include 'public/index.php';
    ?>
    
  5. 我打开浏览器并运行 url (pbm.pbmarketing.ca)。

我在下面收到一条致命错误消息:

致命错误:在第 44 行的 /home/pbmarket/public_html/pbm/init_autoloader.php 中找不到类“Zend\Loader\AutoloaderFactory”

我做错了什么步骤?你能帮我解决这个问题吗?

【问题讨论】:

  • 2.下载了完整的包(ZendFramework-1.12.9)——这是 ZF1 而不是 ZF2!? public_html/vender/ZF2/ 不应该是vendor吗?

标签: php .htaccess zend-framework zend-framework2 shared-hosting


【解决方案1】:

拥有骨架应用程序后,使用 Composer 安装 ZF2(请参阅此处的说明:http://framework.zend.com/manual/2.3/en/ref/installation.html)。由于您使用的是共享主机,因此您可能需要在上传文件之前执行此操作。您不需要下载 ZF 本身(而不是 ZF1!)

我没有在共享主机上使用过 ZF2,因此无法在这方面为您提供帮助,但您当前遇到的错误是因为您没有任何 ZF2 文件。

【讨论】:

  • 蒂姆是对的。使用composer的库太多了,几乎每个php项目都应该使用它。
  • 感谢您的信息,蒂姆。实际上,我能够在本地机器上的 xampp 中安装 Zend Framework 2。我想知道如何将它安装在专用服务器上。假设我在专用托管服务器上的 www.pbmarket.com 下有一个名为 pbm.pbmarket.com 的子域。是否可以在 pbm.pbmarket.com 上安装 zend 框架 2?如果是这样,你能帮我看看怎么做吗?提前致谢。
  • 过程没有什么不同,尽管您可能希望在服务器上运行 composer 命令。
  • 谢谢蒂姆。那么我必须在我的服务器上安装作曲家吗?
猜你喜欢
  • 2011-08-01
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 2015-04-21
  • 1970-01-01
  • 2019-10-09
相关资源
最近更新 更多