【问题标题】:CodeIgniter not working in sub-directoryCodeIgniter 在子目录中不起作用
【发布时间】:2017-06-30 08:52:58
【问题描述】:

我正在使用 CodeIgniter 3.1.1。

问题是当我浏览安装 CodeIgniter 的子目录(http://www.wap.com/demosite)时,它总是重定向到主域,我认为问题出在.htaccess。

例如:

域名:http://www.wap.com

主站目录public_html/

和.htaccess主目录中的文件public_html/.htaccess

RewriteEngine on
RewriteOptions inherit

ErrorDocument 500 /errors/404
ErrorDocument 401 /errors/404
ErrorDocument 403 /errors/404
ErrorDocument 404 /errors/404


RewriteCond %{HTTP_REFERER} !^http://wap.com/.*$      [NC]
RewriteRule .*\.(jpg|jpeg|gif|png|bmp|js)$ - [F,NC]

CodeIgniter 安装目录

public_html/demosite/

和.htaccess子目录public_html/demosite/.htaccess中的文件

RewriteEngine on
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule .* index.php/$0 [PT,L]  

【问题讨论】:

    标签: php apache .htaccess codeigniter mod-rewrite


    【解决方案1】:

    我假设此举是新增功能?

    需要确保在 application/config/config.php 中您的 base_url 设置为 http://www.wap.com/demosite 而不是 http://www.wap.com

    这经常被忽略并导致这些类型的重定向

    你的 codeigniter htaccess 也应该设置为RewriteBase /demosite/

    【讨论】:

      猜你喜欢
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 2011-10-13
      • 1970-01-01
      相关资源
      最近更新 更多