【问题标题】:Unable to restart apache2 server on ubuntu 14.04无法在 ubuntu 14.04 上重新启动 apache2 服务器
【发布时间】:2014-08-14 12:47:11
【问题描述】:

我正在尝试在我的 ubuntu 14.04 中安装 PHP 和 apache2。我通过以下命令安装了 PHP 和 apache2

  $sudo apt-get install php5-cli
  $sudo apt-get install apache2-bin

现在我只想在 ubuntu 系统上重新启动 apache2 服务器。但是在重新启动 apache2 时出现“失败”错误。我在下面提到了错误

AH00558:apache2:无法可靠地确定服务器的完全限定域名,使用 127.0.1.1。

全局设置“ServerName”指令以禁止显示此消息

谁能帮我解决这个错误?

我需要在 ubuntu 14.04 上重新启动我的 apache2 服务器。

【问题讨论】:

    标签: php apache2 ubuntu-14.04


    【解决方案1】:

    问题与您收到的通知无关 试试

    tail -f  /var/log/apache2/error.log
    

    或您系统上的类似位置以检查 Apache 错误日志。这将清楚地告诉您错误在哪里。我得到的最常见的一个是我在vhost配置中指定的日志目录丢失了

    截至通知,添加

    ServerName localhost
    

    到您的配置,它将消失。 如果您的主机名不是 localhost 运行

    hostname
    

    了解它是什么,然后使用适当的值更新 ServerName 指令

    在 ubuntu 上,Apache conf 文件位于

    /etc/apache2/apache2.conf

    【讨论】:

      【解决方案2】:

      终端中的以下两行对我有用。

      1.echo "ServerName localhost" | sudo tee /etc/apache2/conf-available/fqdn.conf
      
      2.sudo ln -s /etc/apache2/conf-available/fqdn.conf /etc/apache2/conf-enabled/fqdn.conf 
      

      希望这也能解决您的问题。

      【讨论】:

      • 最好还是先写一个sudo a2enconf fqdn.conf,然后再写一个sudo service apache reload
      • 感谢您的评论,但对我来说,上述两行工作正常,sudo a2enconf fqdn.conf 给了我终端消息:Conf fqdn 已启用。希望能给这个问题带来更多的启示。
      • 您收到“已启用”消息的原因是 a2enconf 函数的功能与您的第二行完全相同,只是它更易于写入/读取(而且您已经按照自己的方式完成了)。无论哪种方式,您的方法都需要第三行 service apache2 restart 才能完全生效。
      • @WarrenSergent-spakatak.com-感谢分享此信息。
      【解决方案3】:

      您需要设置一个全局 Apache 设置来存储 ServerName localhost(假设 localhost 是您的主机名 - 如果您不确定,可以简单地运行 hostname 来查看)。

      虽然很多人会说将此添加到 /etc/apache2/httpd.conf 或 /etc/apache2/apache2.conf 的末尾(取决于您的版本),但如果您在任何时候更新 Apache,此文件将被覆盖。

      Apache 允许您启用多个配置文件,因此我更喜欢创建一个独立的文件来存储这些信息并加载它。

      # Create a new config file, writing `ServerName localhost` to it
      echo "ServerName localhost" | tee /etc/apache2/conf-available/servername.conf
      # Enable the new config file
      a2enconf servername
      # restart the server
      service apache2 restart
      

      请注意,如果您不使用root 用户,则每个命令都可能需要sudo。 这应该适用于 Debian / Ubuntu,您会注意到该消息在重新启动时消失了。

      【讨论】:

        【解决方案4】:

        在文件/etc/apache2/apache2.conf末尾添加ServerName 127.0.0.1然后重启apache,它会工作

        【讨论】:

          【解决方案5】:

          在您的 apache2.conf 文件中添加以下行 服务器名称 localhost

          程序: 如果您使用的是 Ubuntu 操作系统,那么 1.点击alt+f2 2.输入gedit 3.输入您的密码 4.打开/etc/apache2/apache2.conf 5. 文件结束后键入 ServerName localhost。 现在转到终端并通过键入重新启动 apache2 sudo 服务 apache2 重启 结束了

          【讨论】:

            猜你喜欢
            • 1970-01-01
            • 1970-01-01
            • 2018-01-27
            • 2015-07-20
            • 2016-04-13
            • 1970-01-01
            • 2016-11-21
            • 2014-10-12
            • 2015-10-17
            相关资源
            最近更新 更多