【问题标题】:php5-fpm stack trace cuts off end of stringphp5-fpm 堆栈跟踪切断字符串的结尾
【发布时间】:2015-09-10 05:01:33
【问题描述】:

当一个特别长的字符串被打印到 php5-fpm.log 时,该字符串在末尾被截断,并且显示“...”(不带引号)表示它已被截断。我怎样才能使它显示整个字符串,而不管长度如何?

如果这很重要,我将 Nginx 与 MySQL、PHP 和 Laravel 一起使用。基本上当我在错误日志中打印如下内容时:

error_log(print_r($long_str, TRUE));

如果 $long_str 足够长,它就会被切断。我将它用于调试目的,当我在 Apache 中工作时它运行良好,所以我认为它可能与 Nginx 有关。

我尝试过改变...

log_errors_max_len = 1024

到

log_errors_max_len = 60000

在 /etc/php5/cli/php.ini 和 /etc/php5/fpm/php.ini 中

但它似乎没有做任何事情。如何获取要打印的完整字符串?

【问题讨论】:

    标签: php nginx error-log


    【解决方案1】:

    https://github.com/php/php-src/pull/1076

    这是 php-fpm 中的硬编码限制,上面的拉取请求正在尝试删除限制。添加限制是因为 syslog,以遵循原始 RFC。然而,较新的 RFC 版本取消了该限制,大多数人都要求在 php-fpm 中配置大小和消息格式

    【讨论】:

      猜你喜欢
      • 2013-09-04
      • 1970-01-01
      • 1970-01-01
      • 2012-01-29
      • 1970-01-01
      • 2013-06-23
      • 2015-08-23
      • 2010-11-12
      相关资源
      最近更新 更多