【发布时间】:2012-06-17 14:58:36
【问题描述】:
当我通过 Visual Studio 的 2008 和 php 网页在调试模式下运行我的项目时,我正在使用一个 flex (3.5) 应用程序,该应用程序具有嵌入在与 C# asp.net 网站通信的 php 页面中的 swf我自己的机器一切正常。然后我将所有内容都移到了网络服务器上,现在它只是间歇性地工作,当它不工作时会在闪存日志中产生以下错误:
“错误:由于缺少策略文件权限,请求者从 /php-webpage/swf-file 对 /c#website 的资源请求被拒绝。”
我已经阅读了大量关于策略文件的内容,并且确实了解它们的目的,但我不明白的是,如果我的 php 网页和 C# 项目托管在同一台服务器上,那么我不需要策略文件,因为我没有跨域通信 - 我使用的是同一台服务器?
我在这里遗漏了什么还是只是误解了政策文件?如果没有必要,为什么闪存日志会抱怨策略文件权限?
【问题讨论】:
-
他们在同一个服务器上,但是他们在同一个域上吗?注意
php.mydomain.com和csharp.mydomain.com不是同一个域。 -
如果您的错误是跨域问题;很可能每次都会失败;不仅仅是间歇性的。
-
RIAstar:C#项目和php网站在IIS默认网站下的虚拟目录不同
-
www.Flextras.com:我知道这种间歇性的性质没有任何意义。实际上,我也尝试过将跨域策略放入其中,但它有时仍然有效,并在闪存日志中产生相同的错误消息
-
开启策略文件记录,让我们知道它说了什么……help.adobe.com/en_US/flex/using/…
标签: c# apache-flex security permissions cross-domain-policy