【问题标题】:index.html index.php redirection + Internal Server Errorindex.html index.php 重定向 + 内部服务器错误
【发布时间】:2011-07-11 06:43:10
【问题描述】:

我使用的是 Mac,FTP 与 Transmit 一起使用。 我正在为 Wordpress 上的客户做一个网站。该网站已完成,但我的客户想在网站前面添加另一个页面,因此当您在 Google 中单击 URL 时,您会看到一个带有其徽标的页面,然后单击该页面即可访问 wordpress 网站。

所以:我创建了一个 index.html,dreamweaver 指向“http://www....”并将其上传到 FTP。 wordpress 站点的 index.php 也指向同一个地址。

我在 .htaccess 文件中添加了这段代码:

DirectoryIndex index.html index.php

然后我不得不将 index.html 替换为另一个(相同但内容图像更大以具有全宽)并删除旧的。现在似乎没有任何问题,或者有重复的问题!我有“内部服务器问题,错误 500”。

所以,这个词出来了! 谢谢!

【问题讨论】:

  • 请注意,我们将这类东西称为“启动页”,并且通常被认为是bad idea。说服客户不要这样做可能是值得的。
  • 是的,您绝对应该向您的客户指出可用性问题。
  • 好的。我自己也是这么想的……有没有人知道我怎样才能把它恢复原状?意思是,我只是删除 index.html 并在 .htaccess 中写入: DirectoryIndex index.php ??
  • 如何恢复原来的样子?
  • 您可以简单地删除带有目录索引的行(或在行的开头使用 # 将其注释掉),您还应该删除 index.html 文件(或将其重命名为 index_old .html)

标签: php html indexing redirect


【解决方案1】:

在不知道错误的情况下很难判断到底是什么错误。如果您有权访问任何 apache 日志文件,error.log 会告诉您为什么输出错误。

HTTP 500 状态可以是任何类型的错误,但根据我的经验,最常见的原因是:

  • 某些文件的文件权限不正确
  • .htaccess 文件或 httpd.conf 中的语法错误(我猜您无权访问)

如果您在共享主机上并且您无权访问 apache error.log 文件或者您不知道它在哪里,最好联系系统管理员或支持人员并询问原因您收到错误消息或询问在哪里可以找到 error.log 文件

【讨论】:

  • 我到处阅读,您可以从 apache error.log 中找到问题所在,但我不知道在哪里可以访问它们。例如,在我的日志文件中,它只有 access.log.05 或任何数字...谢谢您的宝贵时间!
  • 那么您可能需要联系系统管理员/支持人员以找出错误所在。甚至可能是他们禁用了覆盖 DirectoryIndex 指令。这可能会导致 500 错误。
  • 好的,非常感谢,我想我会的!
猜你喜欢
  • 1970-01-01
  • 1970-01-01
  • 2016-04-15
  • 2014-01-30
  • 2017-10-24
  • 2021-11-13
  • 1970-01-01
  • 2015-07-20
  • 1970-01-01
相关资源
最近更新 更多