【问题标题】:Error in Publishing a page in Tridion? [closed]在 Tridion 中发布页面时出错? [关闭]
【发布时间】:2012-10-15 08:12:22
【问题描述】:

我正在使用 Tridion 2011。问题是 - 每当我尝试发布页面时,它的发布都会失败。当我检查 Publish Transaction 时,它显示在 Deployment 阶段发布失败。

谁能建议可能是什么问题以及如何纠正它?

谢谢。

【问题讨论】:

  • 检查您的 CD 日志 - 如果错误详细信息未显示在 Publish Transaction 中,则应在此处找到它们。
  • 正如杰里米所说...检查您的日志是否有错误。在 logback.xml 中将日志记录设置为 DEBUG,清理日志,重新启动部署程序并检查发布时获得的堆栈跟踪。
  • 您在使用 HTTP 部署器吗?可以点网页吗?
  • @robrtc :是的,我可以点击 httpupload.aspx 并且我会在页面上看到“SDL Tridion ASPX HTTP Upload”。
  • 请查看部署器配置和 cd_storage 配置。验证存储配置中的目标文件夹是否存在,以验证所有文件是否到位。具体来说,确保 Lib 文件夹中的 Java 文件是正确的。另外,请查看 Nuno 关于手动配置 Tridion 2011 .NET Content Delivery 系统的文章。

标签: tridion tridion-2011 tridion-content-delivery


【解决方案1】:

实际上可能有一百万个部署失败的原因:

  1. 数据库未连接
  2. 数据库配置错误
  3. 磁盘空间不足
  4. 密码错误
  5. 运行部署程序的用户没有写入文件系统的权限

还有更多。

找出问题的最简单方法是查看部署程序提供的日志,您可能会在 cd_core_.log 或 cd_deployer_.log 中找到错误。检查 logback.xml 以了解这些文件的位置。

如果您可以从这些文件中获取错误并将其发布在此处,我们可能会为您提供更好的建议。

【讨论】:

    【解决方案2】:

    尝试在部署包的文件夹上授予用户 -NetworkService 权限。 您还可以指定详细的错误吗?

    【讨论】:

      猜你喜欢
      • 2012-06-11
      • 1970-01-01
      • 1970-01-01
      • 2012-10-29
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      相关资源
      最近更新 更多