【问题标题】:Unable to run IIS7 site from shared folder on linux无法从 linux 上的共享文件夹运行 IIS7 站点
【发布时间】:2017-03-31 02:27:10
【问题描述】:

我有一个在本地运行良好的 IIS 7 应用程序,但由于各种原因,需要从 Linux 共享(Arch 4.8.7-1,ext4 文件系统)运行。 IIS 运行在最新的 VMWare-Player 上的 Win8.1 专业安装上,并且通过 VMWare 播放器共享文件夹进行共享。我可以通过 Visual Studio 打开该项目,但是当我尝试在 IIS 中运行它时,我遇到了权限问题。但是,主机上的文件夹具有完整的 rwx 权限,我登录的任何用户都能够成功访问相关文件。

运行 ProcMon 后,我发现:

1:10:18.0982351 PM  w3wp.exe    4564    NotifyChangeDirectory   \\vmware-host\Shared Folders\Dev\XXX\WEBSITE    INVALID DEVICE REQUEST  Filter: FILE_NOTIFY_CHANGE_FILE_NAME, FILE_NOTIFY_CHANGE_DIR_NAME, FILE_NOTIFY_CHANGE_SIZE, FILE_NOTIFY_CHANGE_LAST_WRITE, FILE_NOTIFY_CHANGE_CREATION, FILE_NOTIFY_CHANGE_EA, FILE_NOTIFY_CHANGE_SECURITY, FILE_NOTIFY_CHANGE_STREAM_NAME, FILE_NOTIFY_CHANGE_STREAM_SIZE, FILE_NOTIFY_CHANGE_STREAM_WRITE

我已经应用了 No Change Notify 修补程序以及注册表更改来强制执行它,但没有让它真正起作用。

有没有办法在 ext4 文件系统上启用 NotifyChangeDirectory?还是完全禁用此“功能”?

IIS 错误:

Module
   IIS Web Core 
Notification
   BeginRequest 
Handler
   Not yet determined 
Error Code
   0x80070001 
Config Error
   Cannot read configuration file  
Config File
   \\?\Z:\XXX\WEBSITE\web.config 

(注意:Z:\ 指向 \vmware-host\Shared Folders\dev)

【问题讨论】:

    标签: linux iis vmware


    【解决方案1】:

    所以,当然,我在发布后立即找到了答案。我找到了这个博客:

    https://blogs.iis.net/ksingla/list-of-registry-keys-affecting-iis7-behavior

    其中显示了一堆注册表项。我加了

    HKLM\System\CurrentControlSet\Services\W3SVC\Parameters\ConfigPollMilliSeconds (REG_DWORD)
    

    并将其设置为 FFFFFFFF。重新启动后,它像梦一样工作。请注意,如果您实际上是在进行开发,您可能希望将其更改为更低(可能是 60k?)。

    【讨论】:

    • 酷。 procmon 是否仍然显示带有 INVALID DEVICE REQUEST 消息的 NotifyChangeDirectory 事件。
    猜你喜欢
    • 1970-01-01
    • 2015-05-16
    • 1970-01-01
    • 1970-01-01
    • 2019-01-02
    • 2013-02-21
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多