【发布时间】:2014-03-30 23:12:38
【问题描述】:
我正在尝试创建一个服务/脚本来自动启动和控制我的 nodejs 服务器,但它似乎根本不起作用。
首先,我把这个来源作为主要参考http://kvz.io/blog/2009/12/15/run-nodejs-as-a-service-on-ubuntu-karmic/
经过测试,我最小化了实际文件的内容以避免任何类型的错误,导致这个(最低限度,但它不起作用)
description "server"
author "blah"
start on started mountall
stop on shutdown
respawn
respawn limit 99 5
script
export HOME="/var/www"
exec nodejs /var/www/server/server.js >> /var/log/node.log 2>&1
end script
文件保存在/etc/init/server.conf
当尝试启动脚本时(以 root 用户或普通用户),我得到:
root@iof304:/etc/init# start server
start: Job failed to start
然后,我尝试使用init-checkconf 检查我的语法,结果是:
$ init-checkconf /etc/init/server.conf
File /etc/init/server.conf: syntax ok
我尝试了其他不同的方法,例如 initctl reload-configuration 没有结果。
我能做什么?我怎样才能让它工作?不会那么难吧?
【问题讨论】:
-
你确定你在 /usr/local/bin/nodejs 有一个文件?
-
@MattPileggi 该死的,你是对的......它不见了。嗯,奇怪,我记得是这样使用 nodejs 的——让我试试别的。结果:没有变化 - 我将命令直接更改为
nodejs,甚至删除了sudo -u部分以以 root 身份执行 - 没有任何变化。我试图直接通过控制台调用该命令 - 这有效。 -
抱歉,不知道还能看什么。我将所有的初始化脚本都设置为永远使用——它负责保持它的运行。你有调查过吗?
-
/var/log/messages 或 boot.log 中关于作业失败消息的任何内容??
-
任何更新,我也收到了!