【问题标题】:How to configure a pre-existed project of PHP with Nginx on Ubuntu 16.04如何在 Ubuntu 16.04 上使用 Nginx 配置预先存在的 PHP 项目
【发布时间】:2017-06-14 12:11:16
【问题描述】:

我有 Ubuntu 16.04; php7-fpm;已安装 Nginx 和 MySql。

我从 Github 下载了一个项目并将其带到 /var/www 并使用以下命令授予权限(kinbuweb 是包含具有 index.php 文件的“公共”文件夹的项目文件夹):

sudo chown -R $USER:$USER /var/www/kinbuweb/public

sudo chmod -R 755 /var/www

我已将 /etc/nginx/sites-available/default 文件复制为模板以在 sites-available 中配置我的文件,并将其修改为指向我的 index.php 文件:

##
# You should look at the following URL's in order to grasp a solid         understanding
# of Nginx configuration files in order to fully unleash the power of  Nginx.
# http://wiki.nginx.org/Pitfalls
# http://wiki.nginx.org/QuickStart
# http://wiki.nginx.org/Configuration
#
# Generally, you will want to move this file somewhere, and start with a clean
# file but keep this around for reference. Or just disable in sites-enabled.
#
# Please see /usr/share/doc/nginx-doc/examples/ for more detailed examples.
##

# Default server configuration
#
server {
listen 80;
listen [::]:80;

# SSL configuration
#
# listen 443 ssl default_server;
# listen [::]:443 ssl default_server;
#
# Note: You should disable gzip for SSL traffic.
# See: https://bugs.debian.org/773332
#
# Read up on ssl_ciphers to ensure a secure configuration.
# See: https://bugs.debian.org/765782
#
# Self signed certs generated by the ssl-cert package
# Don't use them in a production server!
#
# include snippets/snakeoil.conf;

root /var/www/kinbuweb/public;

# Add index.php to the list if you are using PHP
index index.php index.html index.htm index.nginx-debian.html;

server_name kinbu.localhost;

location / {
    # First attempt to serve request as file, then
    # as directory, then fall back to displaying a 404.
    try_files $uri $uri/ =404;
}

# pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
#
location ~ \.php$ {

            include snippets/fastcgi-php.conf;
#
#   # With php7.0-cgi alone:
#   fastcgi_pass 127.0.0.1:9000;
#   # With php7.0-fpm:
    fastcgi_pass unix:/run/php/php7.0-fpm.sock;
}

# deny access to .htaccess files, if Apache's document root
# concurs with nginx's one
#
location ~ /\.ht {
    deny all;
}
}


# Virtual Host configuration for example.com
#
# You can move that to a different file under sites-available/ and symlink that
# to sites-enabled/ to enable it.
#
#server {
#   listen 80;
#   listen [::]:80;
#
#   server_name example.com;
#
#   root /var/www/example.com;
#   index index.html;
#
#   location / {
#       try_files $uri $uri/ =404;
#   }
#}

在我的本地主机文件中,我为本地测试配置页面(这是我的目标) 与sudo nano /etc/hosts 并在我的主机文件中添加了我的 IP 的新更改:

127.0.0.1       localhost
127.0.1.1       tranquilidad
190.165.34.21   kinbu.localhost

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

问题是,当我转到 http://kinbu.localhost/ 时,我收到了 HTTP ERROR 500 并且页面 kinbu.localhost is not working 消息。

这个项目是一个动态项目(我猜)我已经用一个简单的 info.php 文件证明并工作,测试了其他问题的一些答案,但它们已经过时了。我不知道这里发生了什么,我有点新,有什么意见或建议吗?

提前致谢。

【问题讨论】:

  • nginx 错误日志是怎么说的?
  • 你好@vishnuj 我没有语法错误。我用nginx -t 命令检查它。如何查看错误日志?感谢您回答 Vishnuj
  • tail -f /var/log/nginx/error.log
  • 问题似乎出在您的 PHP 脚本而不是 nginx 配置上。
  • @vishnuj 我得到了这个pastebin.com/hVkr4RuV 我该如何解决?

标签: ubuntu nginx localhost php-7


【解决方案1】:

似乎是PHP中的错误。 /var/www/kinbuweb/bootstrap/autoload.php 似乎不见了。您的引导程序安装似乎有些不对劲。

您是否在拥有 composer.json 的地方安装了 composer?

--编辑--

试试这个:

cd /var/www/kinbuweb
/home/luis/composer.phar/composer update --no-scripts
/home/luis/composer.phar install

【讨论】:

  • 感谢@Vishnuj 的回答我有一个 /home/luis/composer.phar 文件,但是在哪里可以找到 composer.json 文件?
  • 在您的项目根文件夹中。你是如何安装引导程序的?
  • Boostrap 已经在项目中。这些是项目的 boostrap 文件夹(/var/www/kinbuweb/bootstrap)中的文件: autoload.php -->pastebin.com/mpk6iDv8paths.php-->pastebin.com/cMf3uQZ5 和 start.php -->pastebin.com/3etg7mGX
  • 你能检查一下/var/www/kinbuweb中是否有composer.json文件
  • 是的,我在 /var/www/kinbuweb 中找到了 composer.json 文件:pastebin.com/7bVuvH79
猜你喜欢
  • 2016-12-06
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 2021-04-05
  • 1970-01-01
  • 1970-01-01
  • 2017-01-29
  • 1970-01-01
相关资源
最近更新 更多