【发布时间】:2017-12-26 07:04:23
【问题描述】:
我在一个Ubuntu Server 17.04上完成了下载Oracle Instant Client、SDK等的全过程。然后用外星人将rpm包转换为deb,安装,设置路径,下载pecl oci8,编译安装(w/o错误)等然后添加行:
extension=/usr/lib/php/20151012/oci8.so
然后重新启动。当我检查 /var/log/apache2/error.log 我看到:
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/20151012/oci8.so' - libmql1.so: cannot open shared object file: No such file or directory in Unknown on line 0
[Thu Jul 20 10:46:44.352631 2017] [mpm_prefork:notice] [pid 23450] AH00163: Apache/2.4.25 (Ubuntu) configured -- resuming normal operations
[Thu Jul 20 10:46:44.352717 2017] [core:notice] [pid 23450] AH00094: Command line: '/usr/sbin/apache2'
有谁知道我可以做些什么来使它工作? 我想我没有启用 selinux 或者是权限问题?
谢谢
【问题讨论】:
-
仅供参考,我已将 extension=/usr/lib/php/20151012/oci8.so 添加到 etc/php/7.0/cli/php.ini,然后执行 php --ri oci8 和一切都很好。我什至可以从命令行运行 .php 连接测试并且效果很好。 storage5.static.itmages.com/i/17/0721/…
标签: php oracle php-7 ubuntu-server oracle-call-interface