【问题标题】:SharePoint error: Web application at xxxx could not be foundSharePoint 错误:找不到 xxxx 处的 Web 应用程序
【发布时间】:2011-06-14 19:31:28
【问题描述】:

当我尝试执行这段代码时:

SPSite siteCollection = new SPSite(@"http://sp-devxxx:10000/");

它会抛出以下错误:

Web 应用程序位于 http://sp-devxxx:10000 不可能 成立。确认您已键入 网址正确。如果 URL 应该是 服务现有内容,系统 管理员可能需要添加一个新的 请求映射到预期的 URL 应用。

我可以从我的网络浏览器访问这个站点,它正在 x64 中编译,我的帐户对内容数据库具有读/写访问权限,代码正在运行该站点的服务器上运行,并且存在访问映射对于这个网站。为什么会抛出这个错误?

【问题讨论】:

  • 是的,我以自己的身份运行,我是管理员/拥有完全访问权限。
  • 服务器上有 PowerShell 吗? (如果你运行的是 sp2010,我猜你是?)
  • @Sam,是的,这就是机器名称。 @xOn,不,我不认为它在机器上。为什么?
  • 我会在此查看备用访问映射。不幸的是,我没有其他线索。

标签: c# .net sharepoint-2010


【解决方案1】:

【讨论】:

  • 试一试,但没有骰子。我认为这仅适用于 401.1 错误,这不是我得到的,对吗?
【解决方案2】:

好的,经过几个小时的痛苦我终于找到了问题......

我必须将自己添加到服务器上的 WSS_ADMIN_WPG 组。希望这对某人有所帮助。

【讨论】:

    【解决方案3】:

    尝试以 Farm Admin 帐户登录。或者,将所需的 SQL Server 角色授予您正在使用的帐户。

    【讨论】:

      【解决方案4】:

      在我的环境中作为应用程序池标识的帐户已经是 WSS_ADMIN_WPG 的成员。我在本地安装了我的网络服务。使用外部域名如

      SPSite siteCollection = new SPSite(@"http://mydomain:123");
      

      失败,报告与海报相同的错误(即使可以从同一台机器上的浏览器访问)。以下工作

      SPSite siteCollection = new SPSite(@"http://localhost");
      

      我还没有弄清楚为什么。

      【讨论】:

      • Sharepoint 中有选项:备用访问映射。可能您需要在那里添加外部域。 technet.microsoft.com/en-us/library/…
      • +1 可能是因为 localhost 自动映射到当前服务器,您在该服务器上运行针对它的脚本。和hosts文件一样(但不需要hosts文件)
      【解决方案5】:

      将目标平台更改为 x64,因为 Sharepoint 2010 仅在 64 位模式下运行

      【讨论】:

        【解决方案6】:

        如果用户的帐户已经是 WSS_ADMIN_WPG 的成员,但问题仍然存在,如 Tim 所述。

        尝试以下步骤:

        1. 转到项目属性
        2. 构建选项卡
        3. 从下拉列表中将平台目标值更改为Any CPU。

        它解决了我们的控制台应用程序的问题。

        【讨论】:

          【解决方案7】:

          在使用 Visual Studio 2012 的控制台应用程序中,我将 Target 框架更改为 3.5....

          【讨论】:

          • 这对我来说是一样的,只是我在 Windows 窗体应用程序中运行。我正在将现有代码移植到一个恰好是 .Net 4.5 的新项目中,但它不会返回该站点。将其更改为 3.5 解决了该问题;我想知道这是不是因为我们使用的是 SharePoint 2010?
          【解决方案8】:

          就我而言,我以管理员身份重新打开了 Visual Studio 2012,问题就解决了。

          【讨论】:

            【解决方案9】:

            我在 SharePoint 服务器上有一个 Web API,我们将其用作从我们自己的数据库中获取数据的媒介。这个 Web API 试图打开网站,我收到了同样的错误。我必须确保所使用的应用程序池身份有权打开网站。

            我将 Web API 应用程序池的标识设置为 SharePointServerFarm,这是我的 SharePoint Web 应用程序使用的标识。

            【讨论】:

              【解决方案10】:

              就我而言,我需要将用户 db_owner 权限添加到 SharePoint_Config、SharePoint_AdminContent 和 WSS_Content数据库,遵循this blog 中的建议。

              【讨论】:

                【解决方案11】:

                Add-SPShellAdmin -UserName domain\username 帮了我大忙。 documentation 表示它仅将用户添加到场配置数据库中的 SharePoint_Shell_Access 角色,并确保将用户添加到每个服务器上的 WSS_Admin_WPG 本地组农场。

                【讨论】:

                  【解决方案12】:

                  我知道这是一个旧的和已回答的线程,但以上都没有对我有用,以下是为将来参考所做的:

                  我有一个 Windows 窗体应用程序创建了一个 sharepoint 2013 站点的实例,并在尝试初始化 SPSite 时给出了上述错误,经过一番搜索后,我发现以下参考资料表明(以及其他可能的解决方案)在与运行实际站点不同的机器上运行代码时可能会出现问题,是的,当我将应用程序移到另一台机器上时它可以完美运行。

                  我知道这不是一个激进的解决方案,但至少你知道问题所在。

                  参考:

                  Common issue: new SPSite API call returns "The Web application at http://server:port/ could not be found."

                  【讨论】:

                    【解决方案13】:

                    将我的代码作为“exe”文件运行时遇到了同样的问题。通过以管理员身份运行 cmd 解决了问题。希望这对某人有所帮助。

                    【讨论】:

                      【解决方案14】:

                      我知道这是很久以前的事了,但就我而言,我必须做两件事:

                      1. 授予对配置数据库的访问权限,用户可以通过编程方式打开 SPSite-object
                      Add-SPShellAdmin -username [domain]\[username]
                      
                      1. 授予对内容数据库的访问权限,用户可以通过编程方式打开 SPWeb 对象
                      Add-SPShellAdmin -username [domain]\[username] -database [content db guid]
                      

                      您可以通过运行以下Get-SPContentDatabase -webapplication [web application url]来获取内容数据库的Guid

                      您可以在这里找到 Timo Pitkäranta 的原始答案:https://blog.stefan-gossner.com/2011/09/18/common-issue-new-spsite-api-call-returns-the-web-application-at-httpserverport-could-not-be-found/

                      【讨论】:

                        猜你喜欢
                        • 1970-01-01
                        • 1970-01-01
                        • 2019-02-19
                        • 2015-08-10
                        • 2019-07-06
                        • 2012-01-19
                        • 1970-01-01
                        • 1970-01-01
                        • 1970-01-01
                        相关资源
                        最近更新 更多