【发布时间】:2017-08-03 11:57:00
【问题描述】:
我想为我编写的 Web 服务设置故障转移。 我到处都读到 docker swarm 1.12 会自动进行故障转移,但我认为只适用于失败的容器。
我应该如何为我的服务配置公共 DNS?
如果主机停机,故障转移如何工作?
使用正常的 dns 循环和节点的 IP,它将无法正常工作。对于 n 个服务器,每第 n 个请求都会失败。如果一台主机关闭,docker route 网格将无济于事。还是我错过了什么?
仅供参考:目前我没有使用 docker swarm,但我打算这样做。
【问题讨论】:
标签: docker dns docker-swarm