【问题标题】:Accessing a Sling Servlet in CQ5在 CQ5 中访问 Sling Servlet
【发布时间】:2014-06-03 10:47:24
【问题描述】:

我们在 CQ5 中创建了一个 Simple Sling Servlet 作为 OSGI 包(使用 cqblueprits/maven/eclipse)。

    import javax.servlet.ServletException;

import org.apache.felix.scr.annotations.sling.SlingServlet;
import org.apache.sling.api.SlingHttpServletRequest;
import org.apache.sling.api.SlingHttpServletResponse;
import org.apache.sling.api.servlets.SlingSafeMethodsServlet;

@SlingServlet(methods = { "GET" }, paths = { "/bin/acme/my/servlet" }, extensions = { "html" })
public class HelloWorld extends SlingSafeMethodsServlet {
    private static final long serialVersionUID = 217529099388338070L;

    @Override
    protected void doGet(SlingHttpServletRequest request, SlingHttpServletResponse response) throws ServletException,
            IOException {
       response.setContentType("text/plain");
       response.getOutputStream().print("Hello AbsoluteUrlServlet World!");
    }
}

如果使用浏览器从浏览器发出请求,则购买

    http://localhost:4502/bin/acme/my/servlet

我遇到了一个错误

    No resource found

Cannot serve request to /bin/acme/my/servlet in /libs/sling/servlet/errorhandler/404.jsp
Request Progress:

  0 (2014-04-18 13:53:24) TIMER_START{Request Processing}
  0 (2014-04-18 13:53:24) COMMENT timer_end format is {<elapsed msec>,<timer name>} <optional message>
  0 (2014-04-18 13:53:24) LOG Method=GET, PathInfo=/bin/acme/my/servlet
  0 (2014-04-18 13:53:24) TIMER_START{ResourceResolution}
  0 (2014-04-18 13:53:24) TIMER_END{0,ResourceResolution} URI=/bin/acme/my/servlet resolves to Resource=NonExistingResource, path=/bin/acme/my/servlet
  0 (2014-04-18 13:53:24) LOG Resource Path Info: SlingRequestPathInfo: path='/bin/acme/my/servlet', selectorString='null', extension='null', suffix='null'
  0 (2014-04-18 13:53:24) TIMER_START{ServletResolution}
  0 (2014-04-18 13:53:24) TIMER_START{resolveServlet(NonExistingResource, path=/bin/acme/my/servlet)}
  1 (2014-04-18 13:53:24) LOG {0}: no servlet found
  1 (2014-04-18 13:53:24) TIMER_END{1,resolveServlet(NonExistingResource, path=/bin/acme/my/servlet)} Using servlet org.apache.sling.servlets.get.DefaultGetServlet
  1 (2014-04-18 13:53:24) TIMER_END{1,ServletResolution} URI=/bin/acme/my/servlet handled by Servlet=org.apache.sling.servlets.get.DefaultGetServlet
  1 (2014-04-18 13:53:24) LOG Applying Requestfilters

在CQ的Error log中,我们可以看到

    18.04.2014 14:19:53.879 *INFO* [0:0:0:0:0:0:0:1 [1397855993874] GET /apps/path/to/my/servlet HTTP/1.1] org.apache.sling.engine.impl.SlingRequestProcessorImpl service: Resource /apps/path/to/my/servlet not found

我无法在 CQ 中部署任何自定义 SlingServlet。为了用 servlet 打包包,我使用的是 Eclipse/Maven/cqblueprints 组合。

请给我们一些解决问题的建议。

【问题讨论】:

    标签: servlets aem sling


    【解决方案1】:

    您为您的 servlet 定义了 html 扩展:

    @SlingServlet(
      methods = { "GET" },
      paths = { "/bin/acme/my/servlet" },
      extensions = { "html" })  // <- here
    

    您需要使用此扩展来访问 servlet:

    http://localhost:4502/bin/acme/my/servlet.html
    

    【讨论】:

    • 我不这么认为。如果设置了 paths 属性,则扩展名将被忽略。
    【解决方案2】:

    如果上面发布的代码是您的整个 servlet 代码,那么它甚至可能由于缺少导入而无法编译。

    如果所有导入都正确且servlet编译正常,则检查该组件是否在Felix控制台中注册在/system/console/components下并处于活动状态。

    由于提到的 servlet 路径是 /bin/acme/my/servlet,您不需要在脚本解析器中注册路径,因为 /bin/ 会默认注册。但如果您使用的是自定义路径,例如 /apps/xyz/abc,请确保您已在 Apache Sling Servlet/Script Resolver and Error Handler 配置中注册了路径,该配置在 /system/console/configMgr 下可用

    【讨论】:

      猜你喜欢
      • 1970-01-01
      • 2014-06-03
      • 2014-12-16
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 2016-09-21
      • 2013-05-16
      • 1970-01-01
      相关资源
      最近更新 更多