【发布时间】:2018-11-26 09:11:52
【问题描述】:
如果我只在 IIS 应用程序中启用 TLS 1.2 是否可行?
当我只应用 TLS 1.2 时,它一直显示以下错误。
如果有 TLS 1.0、1.1、1.2,则 IIS 应用程序确实有效。但显示的属性是 TLS 1.0 而不是 TLS 1.2
【问题讨论】:
如果我只在 IIS 应用程序中启用 TLS 1.2 是否可行?
当我只应用 TLS 1.2 时,它一直显示以下错误。
如果有 TLS 1.0、1.1、1.2,则 IIS 应用程序确实有效。但显示的属性是 TLS 1.0 而不是 TLS 1.2
【问题讨论】:
在 TLS 握手中,服务器将选择客户端支持的最佳协议。鉴于只有当您的客户端连接到支持 TLS 1.0...TLS 1.2 的服务器时,该连接才会产生 TLS 1.0,看来您的(未知)客户端仅支持 TLS 1.0。在这种情况下,如果服务器只启用了 TLS 1.2,它会失败也就不足为奇了。
【讨论】: