【问题标题】:SSL and TLS protocols in IISIIS 中的 SSL 和 TLS 协议
【发布时间】:2018-11-26 09:11:52
【问题描述】:

如果我只在 IIS 应用程序中启用 TLS 1.2 是否可行?

当我只应用 TLS 1.2 时,它一直显示以下错误。

如果有 TLS 1.0、1.1、1.2,则 IIS 应用程序确实有效。但显示的属性是 TLS 1.0 而不是 TLS 1.2

【问题讨论】:

    标签: ssl iis tls1.2


    【解决方案1】:

    在 TLS 握手中,服务器将选择客户端支持的最佳协议。鉴于只有当您的客户端连接到支持 TLS 1.0...TLS 1.2 的服务器时,该连接才会产生 TLS 1.0,看来您的(未知)客户端仅支持 TLS 1.0。在这种情况下,如果服务器只启用了 TLS 1.2,它会失败也就不足为奇了。

    【讨论】:

    • 我的项目框架显示属性为3.5框架,但使用的IIS框架是2.0。有什么办法可以让应用程序在 TLS 1.2 中运行?
    • @whoami:您最初的问题仅在 IIS 中询问有关 TLS 1.2 的问题,并且该问题已得到解答。在您的评论中,您询问的是在特定框架内的客户端启用 TLS 1.2,即一个全新的问题。请不要在评论中提出新问题,而是创建一个具有足够详细信息的新问题来回答它:这样其他人也会看到它,并且可以为您提供有价值的答案,或者如果他们遇到与问题(而不是在一些没有人期望的评论中)。
    猜你喜欢
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2015-05-01
    • 2018-05-06
    • 1970-01-01
    • 2013-09-02
    • 2014-02-02
    • 2015-05-29
    相关资源
    最近更新 更多