【发布时间】:2018-07-11 12:05:33
【问题描述】:
Fobidden message through hostname
我在 aws EC2 上构建了我的网站,并通过 freenom(http://www.freenom.com/en/index.html?lang=en) 购买了主机名。
它之前运行良好,但突然停止,现在只显示禁止消息。
但是当我尝试使用 IP4(http://13.125.106.155/) 或公共 DNS 时,它运行良好。
同样的事情也会发生在其他设备上。
我应该从哪里着手解决这个问题? 或者对这种情况有什么想法?
这里是会议
在 /etc/apache2/apache2.conf 上:
Mutex file:${APACHE_LOCK_DIR} default
PidFile ${APACHE_PID_FILE}
Timeout 300
KeepAlive On
MaxKeepAliveRequests 100
KeepAliveTimeout 5
User ${APACHE_RUN_USER}
Group ${APACHE_RUN_GROUP}
HostnameLookups Off
ErrorLog ${APACHE_LOG_DIR}/error.log
LogLevel warn
IncludeOptional mods-enabled/*.load
IncludeOptional mods-enabled/*.conf
Include ports.conf
关于 /etc/apache2/conf-enabled/security.conf:
ServerTokens OS
ServerSignature On
TraceEnable Off
在 /etc/apach2/ports.conf 上:
Listen 80
<IfModule ssl_module>
Listen 443
</IfModule>
<IfModule mod_gnutls.c>
Listen 443
</IfModule>
【问题讨论】:
-
你能显示你的httpd配置文件吗?
-
我刚刚添加了它们。它在ubuntu上,所以有很多confs。你还需要什么?
-
没有httpd.conf吗?如果不是,指定服务器名称和文档根目录的配置在哪里?
-
它在 ubuntu (unix.stackexchange.com/questions/215157/…) 上。我认为原因是“域名暂停”(strategicrevenue.com/…)
-
感谢您回答这个问题。我试过验证,现在终于搞定了。
标签: amazon-web-services networking dns routing http-status-code-403