【问题标题】:Jetty stops responding after some period of timeJetty 在一段时间后停止响应
【发布时间】:2018-05-24 03:14:00
【问题描述】:

我有一个带有码头网络服务器的项目。 该应用程序已启动并且运行良好。一段时间后(不知道确切时间),如果我尝试访问收到的应用程序:

"您要查找的页面暂时不可用,请尝试 稍后再来。”

该应用还设置了调度程序。我会怀疑超时,但事实并非如此。通过分析我注意到的日志:2017-12-08

12:45:24.566:WARN:oejsh.ErrorHandler:qtp1555845260-195:错误页面 循环 /error/not-found.faces。

我没有看到任何其他可能导致该问题的日志。有什么解决方案的建议吗?

【问题讨论】:

  • 您收到的消息“您要查找的页面暂时不可用。”不是 Jetty 会说的。那来自 Jetty 以外的其他地方。日志消息是有效的。您是否部署在 Unix 机器上?
  • 是的,我使用的是 unix 机器。问题是码头已启动并正常运行。有时几天,有时一天。没有时间定义它何时自行下降,我不知道是什么原因导致它下降

标签: webserver jetty


【解决方案1】:

可能的情况是您在 Jetty 部署中设置了默认工作/临时目录并且您的计算机上有一个进程定期清理系统临时目录。

建议您指定工作目录或临时目录(jvm temp、jetty.base temp 或 webapp temp)。

查看之前关于如何配置工作/临时目录的答案。

【讨论】:

    猜你喜欢
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2015-05-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2016-06-17
    • 1970-01-01
    相关资源
    最近更新 更多