【问题标题】:WebSphere v7.0 doesn't start CREATE_LISTENER_FAILED_4WebSphere v7.0 不启动 CREATE_LISTENER_FAILED_4
【发布时间】:2019-12-30 10:04:37
【问题描述】:

我使用 WebSphere v7.0。当我尝试启动服务器时,控制台上出现以下错误。

[26/08/19 10:02:35:224 CEST] 00000000 WsServerImpl  E   WSVR0009E: Se ha producido un error durante el inicio
 com.ibm.ws.exception.RuntimeError: org.omg.CORBA.INTERNAL: CREATE_LISTENER_FAILED_4  vmcid: 0x49421000  minor code: 56  completed: No
    at com.ibm.ws.runtime.component.ORBImpl.start(ORBImpl.java:439)
    at com.ibm.ws.runtime.component.ContainerHelper.startComponents(ContainerHelper.java:538)
    at com.ibm.ws.runtime.component.ContainerImpl.startComponents(ContainerImpl.java:627)
    at com.ibm.ws.runtime.component.ContainerImpl.start(ContainerImpl.java:618)
    at com.ibm.ws.runtime.component.ServerImpl.start(ServerImpl.java:502)
    at com.ibm.ws.runtime.WsServerImpl.bootServerContainer(WsServerImpl.java:298)
    at com.ibm.ws.runtime.WsServerImpl.start(WsServerImpl.java:214)
    at com.ibm.ws.runtime.WsServerImpl.main(WsServerImpl.java:666)
    at com.ibm.ws.runtime.WsServer.main(WsServer.java:59)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:60)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
    at java.lang.reflect.Method.invoke(Method.java:611)
    at com.ibm.wsspi.bootstrap.WSLauncher.launchMain(WSLauncher.java:213)
    at com.ibm.wsspi.bootstrap.WSLauncher.main(WSLauncher.java:93)
    at com.ibm.wsspi.bootstrap.WSLauncher.run(WSLauncher.java:74)
    at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:78)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:92)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:68)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:400)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:177)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:60)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
    at java.lang.reflect.Method.invoke(Method.java:611)
    at org.eclipse.core.launcher.Main.invokeFramework(Main.java:340)
    at org.eclipse.core.launcher.Main.basicRun(Main.java:282)
    at org.eclipse.core.launcher.Main.run(Main.java:981)
    at com.ibm.wsspi.bootstrap.WSPreLauncher.launchEclipse(WSPreLauncher.java:341)
    at com.ibm.wsspi.bootstrap.WSPreLauncher.main(WSPreLauncher.java:111)
Caused by: org.omg.CORBA.INTERNAL: CREATE_LISTENER_FAILED_4  vmcid: 0x49421000  minor code: 56  completed: No
    at com.ibm.ws.orbimpl.transport.WSTransport.createListener(WSTransport.java:867)
    at com.ibm.ws.orbimpl.transport.WSTransport.initTransports(WSTransport.java:605)
    at com.ibm.rmi.iiop.TransportManager.initTransports(TransportManager.java:157)
    at com.ibm.rmi.corba.ORB.set_parameters(ORB.java:1303)
    at com.ibm.CORBA.iiop.ORB.set_parameters(ORB.java:1690)
    at org.omg.CORBA.ORB.init(ORB.java:364)
    at com.ibm.ws.orb.GlobalORBFactory.init(GlobalORBFactory.java:92)
    at com.ibm.ejs.oa.EJSORBImpl.initializeORB(EJSORBImpl.java:179)
    at com.ibm.ejs.oa.EJSServerORBImpl.<init>(EJSServerORBImpl.java:102)
    at com.ibm.ejs.oa.EJSORB.init(EJSORB.java:55)
    at com.ibm.ws.runtime.component.ORBImpl.start(ORBImpl.java:432)
    ... 29 more

[26/08/19 10:02:35:135 CEST] 00000000 FfdcProvider  W com.ibm.ws.ffdc.impl.FfdcProvid

我检查了文件 serverindex.xml 中的端口 BOOTSTRAP_ADDRESS

 <specialEndpoints xmi:id="NamedEndPoint_1183122129640" endPointName="BOOTSTRAP_ADDRESS">
      <endPoint xmi:id="EndPoint_1183122129640" host="F120000.cargas02.sir" port="2809"/>
    </specialEndpoints>

输出命令netstat -ano是

TCP    0.0.0.0:2809           0.0.0.0:0              LISTENING       4072

我该如何解决这个错误?

【问题讨论】:

    标签: websphere-7


    【解决方案1】:

    通常会发生ORB Listener Thread 创建失败,因为:

    1. 另一个进程已经在监听相关端口(在本例中为 2809)。
    2. ephemeral port range 已在操作系统上扩展,现在 WebSphere 服务器端口范围 (2800 - ~10000) 包含在该范围内,增加了将 WAS 服务器端口号作为临时分配给另一个进程的可能性港口。

    对于场景#1:使用netstat -ano 或lsof -i :&lt;port#&gt; 命令并搜索端口以找到使用该端口的进程。如果发现有冲突的进程,请更改该进程的配置/端口使用情况。或者编辑 dmgr-profile-root/config/cells/cellName/nodes/nodename 中的 WebSphere serverindex.xml 文件(确保采取事先备份)。将 2809 端口更改为另一个未使用的端口。保存并同步更改。

    对于场景#2:选中服务器框上的ephemeral port range(基于操作系统的互联网搜索将给出具体说明)。确保端口范围的低端足够大于 serverindex.xml 文件中的最高 WebSphere 服务器端口。

    最后,WebSphere 服务器也有可能没有正确关闭并关闭之前运行的所有端口。可能需要重新启动操作系统才能释放端口。

    【讨论】:

      猜你喜欢
      • 1970-01-01
      • 1970-01-01
      • 2012-02-14
      • 1970-01-01
      • 1970-01-01
      • 2014-07-14
      • 2015-12-26
      • 1970-01-01
      • 1970-01-01
      相关资源
      最近更新 更多