【问题标题】:AWS User Data fails with invalid region name when it is correctAWS 用户数据在正确时因区域名称无效而失败
【发布时间】:2021-09-27 19:40:07
【问题描述】:

用户数据 bash 脚本失败,提供的 region_name 与支持格式不匹配。

从命令行运行脚本时工作正常。

#!/bin/bash
Hostname=”`wget -qO- http://instance-data/latest/meta-data/hostname`”
InstanceId=”`wget -qO- http://instance-data/latest/meta-data/instance-id`”
Region=”`wget -qO- http://instance-data/latest/meta-data/placement/region`”
echo $Region
aws ec2 create-tags --resources $InstanceId --tags Key=Hostname,Value=$Hostname --region $Region

【问题讨论】:

  • 1.您在Key=Hostname 的主机名之前缺少$ 2. 失败的$Region 是什么?控制台回显了什么?
  • 小心——你的引号字符是非标准的,就好像文本是从 Microsoft Word 而不是纯文本编辑器复制的。我修好了它们,对我来说效果很好。如果您需要调试用户数据脚本,请查看日志文件:/var/log/cloud-init-output.log

标签: amazon-web-services amazon-iam scp policy tagging


【解决方案1】:

修复了 aws 将双引号更改为左右双引号的问题。我重新编码了。

#! /bin/bash
Hostname=$(wget -qO- http://instance-data/latest/meta-data/hostname)
InstanceId=$(wget -qO- http://instance-data/latest/meta-data/instance-id)
Region=$(wget -qO- http://instance-data/latest/meta-data/placement/region)
aws ec2 create-tags --resources $InstanceId --tags Key=Hostname,Value=$Hostname --
region $Region

【讨论】:

  • 我认为您的文本编辑器和您的报价是问题所在,而不是来自 aws。
猜你喜欢
  • 2019-02-23
  • 2017-04-26
  • 1970-01-01
  • 2021-09-22
  • 2014-12-31
  • 1970-01-01
  • 1970-01-01
  • 2020-05-27
  • 1970-01-01
相关资源
最近更新 更多