【发布时间】:2012-08-21 14:23:53
【问题描述】:
在我的 Windows 7 x64 机器上,我尝试从 Visual Studio 2010 SP1 在托管在本地 IIS 上的 ASP.NET 网站上启动调试。我的第一步是配置使用 IIS,并使用 VS 提供的“创建虚拟目录”选项。当我这样做时,我收到此错误:
为 ASP.NET 4.0 配置 Web
http://localhost/MySite失败。您必须为 ASP.NET 4.0 手动配置此站点,以便该站点正确运行。为 ASP.NET 4.0 配置虚拟目录失败。您可能需要为 ASP.NET 4.0 手动配置此站点,以便您的站点正常运行。
这个问题和described here类似,但在我的情况下,确实设置了默认应用程序池。有什么想法吗?
给出错误信息后,弹出另一个对话框,说明虚拟目录创建成功(!!!!!!)。事实上,当我打开 IIS 管理器时,我可以看到新的应用程序。但是,它不起作用;我无法启动网络应用程序。
我有另一台以相同方式配置相同应用程序的机器,但它工作正常。奇怪。
【问题讨论】:
标签: asp.net visual-studio iis