【问题标题】:Unable to install Wordpress on MAMP无法在 MAMP 上安装 Wordpress
【发布时间】:2016-12-18 08:59:07
【问题描述】:

我在尝试安装 Wordpress 时收到此错误消息:

mamp 由于未知错误而退出。请查看日志目录中的 mamp pro 错误日志以获取更多信息。

此外,当我尝试在 MySQL 选项卡下更改 MySQL 密码时,我收到以下错误消息:

mamp 无法更新 mysql 密码。请检查mysql是否正在运行,检查您的配置并重试。

这是我的错误日志:

----apache----

[Thu Aug 11 14:54:25 2016] [warn] pid file C:/MAMP/bin/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Thu Aug 11 14:54:25 2016] [notice] Digest: generating secret for digest authentication ...
[Thu Aug 11 14:54:25 2016] [notice] Digest: done
[Thu Aug 11 14:54:26 2016] [notice] Apache/2.2.31 (Win32) DAV/2 mod_ssl/2.2.31 OpenSSL/1.0.2e mod_fcgid/2.3.9 mod_wsgi/3.4 Python/2.7.6 PHP/7.0.6 mod_perl/2.0.8 Perl/v5.16.3 configured -- resuming normal operations
[Thu Aug 11 14:54:26 2016] [notice] Server built: May  6 2016 10:19:53
[Thu Aug 11 14:54:26 2016] [notice] Parent: Created child process 11620
[Thu Aug 11 14:54:27 2016] [notice] Digest: generating secret for digest authentication ...
[Thu Aug 11 14:54:27 2016] [notice] Digest: done
[Thu Aug 11 14:54:28 2016] [notice] Child 11620: Child process is running
[Thu Aug 11 14:54:28 2016] [notice] Child 11620: Acquired the start mutex.
[Thu Aug 11 14:54:28 2016] [notice] Child 11620: Starting 64 worker threads.
[Thu Aug 11 14:54:28 2016] [notice] Child 11620: Starting thread to listen on port 8888.
[Thu Aug 11 14:55:34 2016] [warn] pid file C:/MAMP/bin/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Thu Aug 11 14:55:34 2016] [notice] Digest: generating secret for digest authentication ...
[Thu Aug 11 14:55:34 2016] [notice] Digest: done
[Thu Aug 11 14:55:35 2016] [notice] Apache/2.2.31 (Win32) DAV/2 mod_ssl/2.2.31 OpenSSL/1.0.2e mod_fcgid/2.3.9 mod_wsgi/3.4 Python/2.7.6 PHP/7.0.6 mod_perl/2.0.8 Perl/v5.16.3 configured -- resuming normal operations
[Thu Aug 11 14:55:35 2016] [notice] Server built: May  6 2016 10:19:53
[Thu Aug 11 14:55:35 2016] [notice] Parent: Created child process 4176
[Thu Aug 11 14:55:36 2016] [notice] Digest: generating secret for digest authentication ...
[Thu Aug 11 14:55:36 2016] [notice] Digest: done
[Thu Aug 11 14:55:37 2016] [notice] Child 4176: Child process is running
[Thu Aug 11 14:55:37 2016] [notice] Child 4176: Acquired the start mutex.
[Thu Aug 11 14:55:37 2016] [notice] Child 4176: Starting 64 worker threads.
[Thu Aug 11 14:55:37 2016] [notice] Child 4176: Starting thread to listen on port 80.

--------

----mysql----

160811 14:54:28 [Note] Plugin 'FEDERATED' is disabled.
160811 14:54:28 InnoDB: The InnoDB memory heap is disabled
160811 14:54:28 InnoDB: Mutexes and rw_locks use Windows interlocked functions
160811 14:54:28 InnoDB: Compressed tables use zlib 1.2.3
160811 14:54:28 InnoDB: Initializing buffer pool, size = 128.0M
160811 14:54:28 InnoDB: Completed initialization of buffer pool
160811 14:54:28 InnoDB: highest supported file format is Barracuda.
160811 14:54:28  InnoDB: Waiting for the background threads to start
160811 14:54:29 InnoDB: 5.5.49 started; log sequence number 1595675
160811 14:54:29 [Note] Server hostname (bind-address): '0.0.0.0'; port: 8889
160811 14:54:29 [Note]   - '0.0.0.0' resolves to '0.0.0.0';
160811 14:54:29 [Note] Server socket created on IP: '0.0.0.0'.
160811 14:54:29 [Note] Event Scheduler: Loaded 0 events
160811 14:54:29 [Note] C:\MAMP\bin\mysql\bin\mysqld.exe: ready for connections.
Version: '5.5.49-log'  socket: ''  port: 8889  MySQL Community Server (GPL)
160811 14:55:30 [Note] C:\MAMP\bin\mysql\bin\mysqld.exe: Normal shutdown

160811 14:55:30 [Note] Event Scheduler: Purging the queue. 0 events
160811 14:55:30  InnoDB: Starting shutdown...
160811 14:55:31  InnoDB: Shutdown completed; log sequence number 1595675
160811 14:55:31 [Note] C:\MAMP\bin\mysql\bin\mysqld.exe: Shutdown complete

160811 14:55:37 [Note] Plugin 'FEDERATED' is disabled.
160811 14:55:37 InnoDB: The InnoDB memory heap is disabled
160811 14:55:37 InnoDB: Mutexes and rw_locks use Windows interlocked functions
160811 14:55:37 InnoDB: Compressed tables use zlib 1.2.3
160811 14:55:37 InnoDB: Initializing buffer pool, size = 128.0M
160811 14:55:37 InnoDB: Completed initialization of buffer pool
160811 14:55:37 InnoDB: highest supported file format is Barracuda.
160811 14:55:37  InnoDB: Waiting for the background threads to start
160811 14:55:38 InnoDB: 5.5.49 started; log sequence number 1595675
160811 14:55:38 [Note] Server hostname (bind-address): '0.0.0.0'; port: 3306
160811 14:55:38 [Note]   - '0.0.0.0' resolves to '0.0.0.0';
160811 14:55:38 [Note] Server socket created on IP: '0.0.0.0'.
160811 14:55:38 [Note] Event Scheduler: Loaded 0 events
160811 14:55:38 [Note] C:\MAMP\bin\mysql\bin\mysqld.exe: ready for connections.
Version: '5.5.49-log'  socket: ''  port: 3306  MySQL Community Server (GPL)
160811 15:01:46 [Note] C:\MAMP\bin\mysql\bin\mysqld.exe: Normal shutdown

160811 15:01:46 [Note] Event Scheduler: Purging the queue. 0 events
160811 15:01:46  InnoDB: Starting shutdown...
160811 15:01:47  InnoDB: Shutdown completed; log sequence number 1595675
160811 15:01:47 [Note] C:\MAMP\bin\mysql\bin\mysqld.exe: Shutdown complete

--------

如果您能为我提供解决方案,将不胜感激。

【问题讨论】:

  • wp-config.php 文件长什么样?
  • 如果 MAMP 因未知错误而退出,您是否重新安装(更新版本)MAMP?

标签: wordpress mamp


【解决方案1】:

MAMP 退出时的事件,有时 MySQL 在后台运行。你能杀掉所有的 MySQL 后台进程再试一次吗?

  1. 退出 MAMP
  2. 打开终端并输入:killall -9 mysqld
  3. 重启 MAMP

【讨论】:

    猜你喜欢
    • 2018-11-28
    • 2015-03-03
    • 2015-04-25
    • 2011-09-28
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2013-12-29
    • 2011-06-08
    相关资源
    最近更新 更多