【问题标题】:Docker app server ip address 127.0.0.1 difference of 0.0.0.0 ipDocker 应用服务器 ip 地址 127.0.0.1 差 0.0.0.0 ip
【发布时间】:2020-03-29 11:32:26
【问题描述】:

他每个人。我正在使用 docker 并尝试对一个简单的 django 应用程序进行 docker 化,该应用程序将外部 http 连接到网页(真实网站) 所以当我在 Docker 文件中设置应该在容器中工作的 django 服务器的地址 - 127.0.0.1:8000。由于无法与网站建立外部连接,我的应用无法运行。

但是当我为我的服务器设置端口时:0.0.0.0:8000它开始工作了。

所以我的问题是:为什么会这样?在这种特殊情况下有什么区别?我只是想了解一下。

我阅读了一些关于 0.0.0.0 的文章,它就像一个允许使用 OC 默认端口的“通用”或“占位符”端口。

127.0.0.1 就像一个将请求重定向到当前机器的主机。我就知道。 但是当我在我的本地机器(主机:127.0.0.0:8000)上运行应用程序时,一切正常,应用程序可以连接到真实网站,但如果是 docker,它就停止工作了。

感谢您的帮助!

这是我的来源: 码头工人文件

FROM python:3.6

RUN mkdir /code
WORKDIR /code

COPY requirements.txt ./
RUN pip install --no-cache-dir -r requirements.txt

COPY . ./

EXPOSE 8000

ENTRYPOINT [ "python", "manage.py" ]
CMD [ "runserver", "127.0.0.1:8000" ] # doesn't work
# CMD [ "runserver", "0.0.0.0:8000" ] - works

docker-compose.yml

version: "3"
services:
  url_rest:
    container_name: url_keys_rest
    build:
      context: .
      dockerfile: Dockerfile
    image: url_keys_rest_image
    stdin_open: true
    tty: true
    volumes:
      - .:/var/www/url_keys
    ports:
      - "8000:8000"

这是我在 127.0.0.1 的情况下收到的 http 错误。也许会有用。

http: error: ConnectionError: HTTPConnectionPool(host='127.0.0.1', port=8000): Max retries exceeded with url: /api/urls (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x10cd51e80>: Failed to establish a new connection: [Errno 61] Connection refused')) while doing GET request to URL: http://127.0.0.1:8000/api/urls

【问题讨论】:

    标签: django docker tcp docker-compose ip


    【解决方案1】:

    您必须将容器的主进程设置为绑定到特殊的 0.0.0.0 “所有接口”地址,否则将无法从容器外部访问。

    在 Docker 127.0.0.1 中几乎总是意味着“这个容器”,而不是“这个机器”。如果您从容器建立到 127.0.0.1 的出站连接,它将返回到同一个容器;如果您将服务器绑定到 127.0.0.1,它将不接受来自外部的连接。


    Docker 所做的其中一项核心工作就是为每个容器提供自己独立的网络空间。特别是,每个容器都有自己的lo 接口和自己的localhost 概念。

    在非常低的级别,网络服务调用 bind(2) 系统调用来开始接受连接。这需要一个地址参数。它可以是以下两种情况之一:可以是某个系统接口的 IP 地址,也可以是特殊的 0.0.0.0 “所有接口”地址。如果您选择一个接口,它将只接受来自该接口的连接;例如,如果您在一个物理系统上有两个网卡,您可以使用它来只接受来自一个网络的连接,而不接受另一个网络。

    因此,如果您将服务设置为绑定到 127.0.0.1,即为lo 接口的地址,该服务将只接受来自该接口的连接。但是每个容器都有自己的lo 接口和自己的localhost,所以这个设置会导致服务拒绝连接,除非它们是从容器本身启动的。如果您将其设置为绑定到 0.0.0.0,它还将接受来自每个容器 eth0 接口的连接,来自容器外部的所有连接都到达该接口。

    【讨论】:

    • 感谢您的回答。老实说,我读了几遍只是为了理解它,因为这个解释太technical。所以我目前的知识水平还不足以100%理解,但我理解了一些东西,至少是一点点。谢谢。
    【解决方案2】:

    我的理解是 docker 是随机分配 IP 地址给每个容器,而不是 localhost(127.*.*.*)。因此使用 0.0.0.0 在 docker 应用程序内部进行监听将起作用。在使用 localhost 之前,我尝试在 docker 文件中连接本地数据库。它也不起作用。我想是由于这个原因。如果我错了请纠正我!

    更新:我附上一张直观的图片来展示 docker 如何与这些 IP 地址交互。希望这有助于理解。

    【讨论】:

    • 如果您尝试通过以下方式访问 URL:url_rest:8000,您将获得您的 API。和zh​​en404一样难过,Docker每次都是随机的ip。
    • 谢谢你。在我看来,在某些情况下你是对的
    猜你喜欢
    • 1970-01-01
    • 1970-01-01
    • 2015-06-21
    • 2016-09-11
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多