【问题标题】:No buffer space available (maximum connections reached?没有可用的缓冲区空间(达到最大连接数?
【发布时间】:2013-08-22 04:57:18
【问题描述】:

我有一个相当令人沮丧的问题,因为我在与无法运行或完成的查询相关的日志中出现错误,这很奇怪,因为页面通常很好,进一步调查显示错误:

Caused by: java.net.SocketException: No buffer space available (maximum connections reached?): connect

我在 Windows Server 2008 R2 数据中心(1 个 CPU)、MySQL 5.0.85 和 mysql-connector-java-5.1.25 上运行 Tomcat 6。

我在访问我们的网站时没有遇到任何页面抛出错误,但某些用户一定遇到了问题,因此出现了错误日志。大海捞针突然浮现在脑海中,如果有人能说明一下解决方案,将不胜感激:-)

【问题讨论】:

    标签: mysql tomcat windows-server-2008-r2


    【解决方案1】:

    假设您的 CPU 中有多个内核,这通常是由于 Windows Server 2008 R2 中的错误 (ID 2577795) 造成的。可从Microsoft 获得修补程序。

    【讨论】:

    • 如前所述的单 CPU,所以我觉得修复无济于事,但谢谢。
    • 我将此建议转发给托管公司,起初他们不同意,但后来改变了主意,所以不确定发生了什么,他们已经应用了补丁,但不幸的是这仍然没有解决问题.
    【解决方案2】:

    我将所有项目迁移到 Tomcat 7.0.42 并且我的错误消失了,我们的网站更加稳定且速度稍快,我们使用的内存更少,cpu 使用率也更好。

    【讨论】:

      猜你喜欢
      • 2011-08-29
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      相关资源
      最近更新 更多