【发布时间】:2019-04-20 07:53:42
【问题描述】:
我一直在尝试将应用程序部署到 Azure 应用程序服务(免费层),但由于内存限制,该应用程序由于占用过多内存而不断被终止。当然,解决这个问题最简单的方法是在启动时在 JVM 上设置-Xmx900m,但是到目前为止我尝试过的方法都没有奏效。
我尝试过的:
- 将
-Xmx900m添加到web.confighttpPlatform标记的arguments属性中(在开头)。 - 在 JAVA_OPTS 环境变量中添加了
-Xmx900m(在应用程序设置中) - 使用
web.config文件将-Xmx900m添加到JAVA_OPTS 环境变量中。
问题是我无法验证这些中的任何一个是否真的有效,因为在 Kudu 中,我看不到所使用的命令行,或者除了查看它使用了多少内存之外,我看不到它在任何时候都使用了多少内存来检查进程。给定的时刻。在每种情况下,似乎该设置都被忽略了,因为内存使用量攀升至 1024MB,然后进程因内存分配失败而崩溃。
我可以做些什么来设置 Azure App Service Java 应用程序中的最大堆设置吗?
【问题讨论】:
标签: java azure azure-web-app-service