【发布时间】:2016-05-31 14:13:24
【问题描述】:
我创建了一个云服务来获取错误日志并将其托管在 Azure 上。它在那里工作得很好,但是当我在 IIS 上托管相同的应用程序时,它给出了 错误。
说明:在执行当前 Web 请求期间发生未处理的异常。请查看堆栈跟踪以获取有关错误及其源自代码的位置的更多信息。
异常详细信息:System.Net.WebException:无法解析远程名称:'xxx.table.core.windows.net'
我不应该显示代码片段。我也知道The remote name could not be resolved 存在重复的帖子,但那里的答案无法消除我的错误。任何帮助表示赞赏
【问题讨论】:
-
一个天蓝色的表就像一个休息服务端点..你能在同一个盒子上从提琴手或休息客户端点击相同的 URL 吗?如果不是,则与 IIS 无关,也可能与连接或 DNS 问题有关。
-
@RajaNadar 但是相同的代码在 localhost 和 Azure 上运行良好
-
同意拉贾。另外请检查是否有防火墙/代理可能会阻止连接。
标签: c# asp.net azure azure-table-storage