【发布时间】:2021-10-12 05:50:12
【问题描述】:
我是 Docker 和 CI\CD 的新手 我正在使用带有 Ubuntu 18.04 的 vps。 该项目的docker在本地运行并且工作正常。 我不太明白为什么服务器试图在 http 上找到 docker,而不是在 tcp 上。
- override.conf
[Service]
ExecStart=
ExecStart=/usr/bin/dockerd
码头服务状态
- daemon.json
{ "storage-driver":"overlay" }
- gitlab-ci.yml
image: docker/compose:latest
services:
- docker:dind
stages:
- deploy
variables:
DOCKER_DRIVER: overlay2
DOCKER_TLS_CERTDIR: ""
deploy:
stage: deploy
only:
- master
tags:
- deployment
script:
# - export DOCKER_HOST="tcp://127.0.0.1:2375"
- docker-compose stop || true
- docker-compose up -d
- docker ps
environment:
name: production
- 错误
【问题讨论】:
-
请编辑您的问题并在问题正文中添加代码、日志、输出、错误消息...作为代码块。使用图像通常几乎不可读,它会削弱搜索引擎对内容进行索引的能力,视障人士无法使用他们的语音合成器,试图帮助您的人无法在需要时复制/粘贴内容,它使用的数据量是等效文本的 1000 倍.最重要的是,它在How to ask 中被明确列为不良做法。谢谢
-
好的,我会的,谢谢@Zeitounator。
-
如果您的作业启动失败,应该从服务容器输出日志。您可以在错误上方分享作业日志的任何相关部分吗? (第 1 行 -> 105)。您的工作正在尝试连接
127.0.0.1:2375,这对于这种设置是不正确的。
标签: linux docker docker-compose gitlab-ci cicd