【发布时间】:2021-11-18 10:45:37
【问题描述】:
我因该错误一周后被阻止。
“应用程序抛出了一个未处理的异常。 System.ArgumentNullException:值不能为空。 (参数'connectionString')"
我在 Linux 上的 Apache 中的 Asp.Net Core 中部署了一个应用程序。
我可以访问这些页面,但是当它需要调用数据库时,它给了我这个错误。
当我在 Windows 上本地使用它时,一切正常,我可以使用相同的 connectionString 访问数据库。
我不明白为什么在我构建项目并部署它时它不起作用。
谁能帮帮我。
这是我的连接字符串:
{
"ConnectionStrings": {
"DefaultConnection": "Data Source=IP SERVER;Initial Catalog=Database;User ID=SA;Password=Password"
},
我已经在 Azure 上部署了该应用程序,并在 Azure 上使用了 SQL 数据库,也许是因为这个原因?
【问题讨论】:
标签: asp.net linux database apache deployment