【问题标题】:Kafka Server Properties - unable to connect to brokerKafka 服务器属性 - 无法连接到代理
【发布时间】:2017-10-29 11:08:51
【问题描述】:

假设 Kafka 在 AWS EC2 实例上作为单节点代理运行。该实例具有内部私有 IP 10.0.0.1。我想直接从同一个 EC2 实例和同一个 VPC 和子网中的另一个 EC2 实例连接到该代理。安全组允许连接。 我必须使用哪些设置才能使连接运行?

我试过listeners=PLAINTEXT://0.0.0.0:9092 和advertised.listeners=PLAINTEXT://0.0.0.0:9092。使用该设置,我可以从本地(运行代理的同一实例)连接到代理,但我无法从第二个 EC2 实例访问代理。

有人知道吗?

【问题讨论】:

  • 您是否收到任何可以分享的错误消息?
  • 我只收到超时错误。

标签: amazon-ec2 apache-kafka


【解决方案1】:

如果您尝试将 AWS 内的 Kafka 实例从一个 EC2 实例连接到另一个实例,则内部 IP 地址应该可以工作。

生产者和消费者也应该为代理和动物园管理员使用内部私有 IP 地址。

此外,您可能需要验证操作系统级别的 IP 表没有阻塞通信。

【讨论】:

    猜你喜欢
    • 1970-01-01
    • 2021-04-29
    • 1970-01-01
    • 2017-06-25
    • 1970-01-01
    • 2018-10-18
    • 2021-12-22
    • 1970-01-01
    • 2021-08-28
    相关资源
    最近更新 更多